Diesel Forum - TheDieselStop.com - Reply to Topic
Power Stroke Excursions Technical discussion of the Ford Excursion SUV with the Power Stroke diesel.

Thread: Dead truck Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
04-21-2019 01:17 PM
BlueOx1 I got it started filled the filter as far as I could and cycled the key about 10 times and tried cranking it off and on for about a hour and got it to start. I think the pick up rotted off the tank though and I will probably drop the tank in the next week or so. Unfortunately my other vehicle was down for a a air conditioning compressor,condenser. So my family got to see the joys of riding around in my 08 e350 work van. Thanks for the ideas, On a side note is it just the intank housing you replace or do you order the filter sock and prescreen separately from the intank housing?
04-20-2019 10:35 PM
klhansen Maybe you need to prime the new pump. They won't pump air all that well. Try putting a shop vac with the hose connected to blow air over the tank filler and pressurize the tank a bit when you turn the key on.
04-20-2019 07:25 PM
absolutezero273c BlueOx1, is it possible you have any type of debris in tank clogging the pickup? Or possibly a blocked vent tube in the back preventing air from getting in?
04-20-2019 02:05 PM
BlueOx1
Dead truck

Coming home the other night truck starts sputtering like it's not getting fuel. I'm about a mile from the gas station,tank is a just under a 1/4 full. Tried to make it but it just died. Towed it home ,started looking at it fuel bowl empty and fuel pump runs . Put a hose from back of pump into 5 gallons of diesel and cycled the key about 5 times and sucked nothing to the bowl. Figured pump was done, installed new pump on truck cycled key 5 or 6 times and pump runs but doesn't fill fuel bowl. I'm thinking the foot rotted off in the tank ,or am I missing something. I haven't tried putting the new pump in the 5 gallons of diesel but figured it should of been able to suck it through the lines. I filled the fuel bowl hoping for it to start but it just cranks and doesn't give any puffs of smoke from the exhaust. Let me know your thoughts.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome