Diesel Forum - TheDieselStop.com - Reply to Topic
7.3L IDI Diesels (Not Power Strokes) Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

Thread: Front tank won't take fuel Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
06-26-2019 07:43 PM
Steve83 New floats are common & affordable. I bought a few spares last time I needed 2.


(phone app link)


Check Amazon & ebay.
06-26-2019 08:32 AM
caseyj I did what you did but the problem came back. Finally went to this type with no more problems.


06-25-2019 06:09 PM
coreywj454 well i spent saturday fixing the filling issues.... and it turned out it was not a filling issue. Here i thought the whole time the tank was empty because the gauge was reading empty but turns out the damn tank was full and that is why it wasn't filling. I dropped the tank and pulled the sending unit. reconnected it to the truck electrical and moved the float up and down manually and the gauge moved accordingly. so i thought maybe it just got stuck or something. so i put it back in and the damn thing read empty. so i pulled it back out and took the float off of the wire.... the damn float was full of fuel so it wasn't floating. i drilled a hole in it, drained it, patched the hole with JB weld, then I took an eye drop container, hose clamped it to the float, snapped it back into place, put the sending unit back in and it is all working now.
06-21-2019 12:14 AM
Steve83 This shows what I did:


(phone app link)
06-20-2019 09:20 PM
oldrebuiltdodge If the hose is too long, it will be a problem too. It should end right at the end of the outside hose
06-19-2019 09:43 PM
coreywj454 The rear tank is good to go. I can't see much into the front tank, i tried. the utility body on my truck makes it real hard to get in there, so I am just going to drop it and go from there. I am wondering if there was a filler hose and it broke off and is blocking the tank inlet.
06-19-2019 03:01 PM
Steve83 Pex is more rigid & durable than rubber fuel hose - it won't collapse like hose does.

But it takes years for the hose to degrade, so it sounds like there's some other problem with your tanks. Did you try to look inside them while the filler hoses were off?
06-19-2019 07:56 AM
coreywj454 I got some 1 inch hose and installed it. I am still having the same issue. it is acting like the fuel can't get into the tank. I think I am going to just drop the tank and see what is going on.
06-18-2019 05:08 PM
oldrebuiltdodge Yes 1 inch is the correct size.
06-18-2019 08:51 AM
coreywj454 is 1 inch the size hose i need? I think I am more comfortable just getting fuel hose than going the pex route.
06-17-2019 07:28 PM
oldrebuiltdodge Do yourself a favor, and put the inner hose in the back one too.
06-17-2019 07:23 AM
coreywj454 My truck only has the outer hose so I am thinking thats the problem. I am going to take everything off back to the tank inlet and re-do it with an inner and outer hose and hopefully that solves the problem. My rear tank did not have the inner hose either but it seems to fill alright.
06-16-2019 11:23 PM
Steve83 The vent is the outer hose; the filler is the inner one.


(phone app link)


I recently repaired a '97 gasser flatbed by removing both filler neck assemblies, pulling the outer hoses, then the inner hoses, and replacing the inners with 1" PEX tubing from a hardware store. I used a common 110VAC heat gun to form it to follow the original hose's contour (checking frequently on the truck), and then put the outer hose back on before final installation.
06-16-2019 04:08 PM
coreywj454
Front tank won't take fuel

Hi Guys. I am reviving my IDI. The rear tank sending unit broke off and the front tank won't take fuel so it has been parked for a while. I dropped the rear tank and installed a new 40 gallon and modified the old sending unit to work with it. Now I am on to the front tank. It will not take fuel. My truck has a utility bed and I always thought it was an issue with the angle but today I loosened the hose from the filler and tried to put diesel into the tube at a better angle and the tank still won't take on fuel. Is this just a venting issue? Or is there something else I should be looking at?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome