Diesel Forum - TheDieselStop.com - Reply to Topic
'99 & up 7.3L Power Stroke Engine and Drivetrain Discussion of the '99 & up 7.3L Power Stroke diesel engine and drivetrain in the 1999-Up Super Duty trucks and Excursions. No gas engine discussion allowed except on transmissions and drivetrain that pertain to all models. Please confine discussion of topics in this forum to those items that are specific to the 7.3L Power Stroke engine.

Thread: Poor fuel economy??? Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-17-2019 12:13 PM
RT I missed where he said he removed the sensor. He did say he removed the exhaust back pressure valve, but that is a common delete and has no affect on the sensor.
08-17-2019 11:52 AM
Absolute Once again. Removing the back pressure sensor will directly effect your fuel economy. In fact, on a diesel that's all it helps the CPU with. It helps the CPU determine fuel mixture along with other sensors of course. So you removed one of its equations and it runs on default now. Which will be rich, which will drop your fuel economy. 2 mpg would be about right over a tank a bit rich. Put it back, and your CPU will then be able to calculate fuel economy with your new add ons, and fuel economy will be better than before most likely. If not the same. The CPU already recognizes your add ons, but has lost part of its information network without back pressure, and cant take advantage of your add ons because it must run rich on default information. Default will never run lean. Lean doesn't keep your truck running in a sensor loss situation. So all vehicles will either run rich on default, or de rate hp and run rich like a semi truck does with sensor loss.
08-10-2019 12:29 PM
Rickie
Quote:
Originally Posted by jobaa View Post
I installed a K&N filter along with a 4" exhaust with straight through muffler, new bellowed up pipes and deleted the back pressure valve. Didn't change anything else. My fuel economy dropped by about 2 MPG. Anybody have any ideas? Did I do something I shouldn't have? It seems that these mods should improve economy and performance but neither is better. The only thing I've noticed is a different exhaust tone and I can hear the turbo whistling a bit more.
The exhaust should sound different, youíve removed the original set up..

Since youíve changed a few items, any single one may be the culprit. As mentioned above, I hope itís just data from only one fill up. You need a few fill ups/tanks of fuel before you want to compare data sets.
08-03-2019 07:53 AM
Absolute I used to have problems with my back pressure sensor. It would malfunction and shut the truck down. Unplugged I could get going again. That said. The only difference I noticed with it unplugged was crappy fuel economy. Plug back in and all good again, once I replaced the sensor. So, Im guess its your missing back pressure sensor.
08-02-2019 05:45 PM
RT Check for boost leaks. That would be a sure source of decreased fuel economy. You can buy or build a leak tester.
08-02-2019 04:12 PM
bugman If mods improved mileage as much as they claim to they would put the oil refineries out of business.

So, how are you checking the mileage? Using math or the lie-o-meter? How many tanks of fuel have you ran through since doing these mods? Did you change your driving style?

Sent from my SM-J737V using Tapatalk
08-02-2019 03:50 PM
jleedog What kind of K&N did you use? Most of us agree that they are not the greatest filters to use on our trucks. Is it the K&N direct stock replacement filter?Did you oil it? You may have restricted flow if you did, which would explain the drop in MPG. I recommend the ford AIS air filter setup if you really want a good filter. Take out the K&N and put the old filter back in and recheck your MPG. A new exhaust would not typically cause a drop in MPG but a exhaust or turbo/up pipe leak might. Check for leaks on the new up pipes. Did you loose any boost after the new work?
08-02-2019 01:51 PM
jobaa
Poor fuel economy???

I installed a K&N filter along with a 4" exhaust with straight through muffler, new bellowed up pipes and deleted the back pressure valve. Didn't change anything else. My fuel economy dropped by about 2 MPG. Anybody have any ideas? Did I do something I shouldn't have? It seems that these mods should improve economy and performance but neither is better. The only thing I've noticed is a different exhaust tone and I can hear the turbo whistling a bit more.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome