Diesel Forum - TheDieselStop.com - Reply to Topic
6.0L Power Stroke Engine and Drivetrain Discussion of the 6.0L Power Stroke diesel engine and drivetrain in the 2003-Up Super Duties and Excursions. No gas engine discussion allowed except on transmissions and drivetrain that pertain to all models. Please confine discussion of topics in this forum to those items that are specific to the 6.0L Power Stroke engine.

Thread: 6.0 powerstroke long crank Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Diesel Forum - TheDieselStop.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-12-2019 08:38 PM
bomhour
Quote:
Originally Posted by dillon134 View Post
You should download one of the monitoring apps like forscan. I think you'll need a wireless dongle to connect it to the vehicle.
You are correct. The Forscan lite app for iphone monitors all of the PID's you mentions. And yes, you need a wifi odbii adapter from Amazon. the whole setup cost about $30



08-11-2019 12:20 AM
dillon134
Quote:
Originally Posted by gsch2 View Post
well i did get some dummy plugs replaced but i don’t know how many. that was my idea at first but it’s still makes a weird noise. i see there anyway i can attach a video somehow?
There is a wealth of knowledge on this forum for you to review. You should just go through similar threads and learn from those that came before you. I was new to Diesels about 7 years ago and now can do all of my own work. There are 2 dummy plugs and 2 stand pipes. Each can have o-ring failures that cause the symptoms that you have described.

There are also TONS of videos on YouTube about 6.0's.
08-10-2019 12:09 AM
gsch2 well i did get some dummy plugs replaced but i don’t know how many. that was my idea at first but it’s still makes a weird noise. i see there anyway i can attach a video somehow?
08-10-2019 12:06 AM
gsch2
Quote:
Originally Posted by bobofthenorth View Post
"It only happens when it sits" For a couple of minutes? For a couple of hours? Overnight?

You're going to have to figure out how to get some real numbers - otherwise we're just throwing darts at the wall.
well it starts hard anywhere after sitting for a couple of hours so overnight and stuff
08-09-2019 01:38 PM
dillon134
Quote:
Originally Posted by gsch2 View Post
Quote:
Originally Posted by gsch2 View Post
Quote:
Originally Posted by dillon134 View Post
It would help if you could provide us some data. What are your ICP and IPR values while you are cranking? How long does it take to turn over? What year 6.0 do you have?
i don’t have anything to test that
it’s a 2006.
It being an 2006 6.0L, I'm kind of surprised that you needed a new HPOP as they have been known to be pretty stout. The earlier model 6.0's had weaker HPOP's that were problematic. Long crank sounds like a leak in the HPOP system to me. Maybe the dummy plugs or stand pipes need to be replaced. Also, I would hope that your mechanic installed an newer updated STC Fitting on the HPOP.

You should download one of the monitoring apps like forscan. I think you'll need a wireless dongle to connect it to the vehicle.
08-09-2019 01:33 PM
bobofthenorth "It only happens when it sits" For a couple of minutes? For a couple of hours? Overnight?

You're going to have to figure out how to get some real numbers - otherwise we're just throwing darts at the wall.
08-09-2019 07:59 AM
gsch2
Quote:
Originally Posted by gsch2 View Post
Quote:
Originally Posted by dillon134 View Post
It would help if you could provide us some data. What are your ICP and IPR values while you are cranking? How long does it take to turn over? What year 6.0 do you have?
i don’t have anything to test that
it’s a 2006.
08-09-2019 07:57 AM
gsch2
Quote:
Originally Posted by dillon134 View Post
It would help if you could provide us some data. What are your ICP and IPR values while you are cranking? How long does it take to turn over? What year 6.0 do you have?
i don’t have anything to test that
08-08-2019 11:05 PM
dillon134 It would help if you could provide us some data. What are your ICP and IPR values while you are cranking? How long does it take to turn over? What year 6.0 do you have?
08-08-2019 09:32 PM
gsch2 and it only happens when it sits
08-08-2019 08:59 PM
gsch2
6.0 powerstroke long crank

so when i start cranking on my 6.0 it takes a good amount of time. i just got the oil cooler and hpop replaced. it starts better but makes a clunking noise for like 2 seconds then stops. opinions?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome