Diesel Forum - TheDieselStop.com - Search Results
Advanced Search
Showing results 1 to 4 of 4
Search took 0.00 seconds.
Search: Posts Made By: antigrav1117
Forum: 7.3L IDI Diesels (Not Power Strokes)   05-03-2019, 08:45 PM
Replies: 19
Views: 12,932
Posted By antigrav1117
OK -so I bought a Chinese tester, guess what? It...

OK -so I bought a Chinese tester, guess what? It works! My old injectors were all over the map, most 1850-1900, one was 1400, one was 2400! Plus they didn't "pop" they kinda just took a diesel...
Forum: 7.3L IDI Diesels (Not Power Strokes)   04-19-2019, 10:31 AM
Replies: 4
Views: 305
Posted By antigrav1117
Talking Update

Thanks Oldrebuilt- I am now a believer- LOL. Well, turns out this issue was a faulty Engine Overtemp sensor that I sprayed with oven cleaner and then a garden hose (stream). I likely damaged it. ...
Forum: 7.3L IDI Diesels (Not Power Strokes)   04-17-2019, 06:50 PM
Replies: 4
Views: 305
Posted By antigrav1117
Update- trip home from work- the gauge came off...

Update- trip home from work- the gauge came off full hot, enough so that the idiot light went out, then it dropped more, now back into normal range.. what the heck?? LOL - no more oven cleaner on the...
Forum: 7.3L IDI Diesels (Not Power Strokes)   04-17-2019, 10:46 AM
Replies: 4
Views: 305
Posted By antigrav1117
Unhappy Temp sensor scare

'91 F250, 7.3L idi. On my way to work, idiot light "Engine" came on. I glanced at it, then saw the Engine temp gauge BURIED to the right. Truck was running normal, but I panicked, pulled over and...
Showing results 1 to 4 of 4

 
Forum Jump
 
For the best viewing experience please update your browser to Google Chrome