The Diesel Stop banner
1 - 17 of 17 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Recently installed a hydra chip, stating this because I don't know if maybe it has something to do with the issue, but gave it about a day then I'll go to give it full throttle or anything above 1/4 throttle and she just lights the dash up for about a second or to returning to an idle. I've seen alot on the posts of it being a cps or tps or the ivs but before I go and dump a crap load of money trying to problem solve I'd figure its worth giving this a shot. Also zf6 manual when it's in neutral I can go through the full Rev range, only when it'd in gear does it cut power completely
 

·
Administrator
Joined
·
27,479 Posts
Start by removing the chip and see if the problem is still there.

If the SES light comes on (even for a second) there will be a code stored. You'll need a Powerstroke capable scan tool to get that code. Unless you get the code, you're just guessing.
 

·
Registered
Joined
·
744 Posts
So, look up the GB Tech bulletin #130 here on this site. It tells you how to test the harness for the IDM before you go and replace the IDM. Usually it's a harness issue.
 
  • Like
Reactions: Wtschopp99

·
Registered
Joined
·
11 Posts
Discussion Starter · #9 ·
So, look up the GB Tech bulletin #130 here on this site. It tells you how to test the harness for the IDM before you go and replace the IDM. Usually it's a harness issue.
upon inspection of the plugs going into the valve cover harness, it seems the one side has wiggled lose, not completely unplugged, pushed it back in gonna see if this has resolved the issue
 

·
Registered
Joined
·
744 Posts
upon inspection of the plugs going into the valve cover harness, it seems the one side has wiggled lose, not completely unplugged, pushed it back in gonna see if this has resolved the issue
If one side wiggled loose it would have showed up in the tech bulletin test
 

·
Administrator
Joined
·
27,479 Posts
Here's the PCM pinout.
 

Attachments

·
Administrator
Joined
·
27,479 Posts
Engine Harness connector (42 pin)
 

Attachments

·
Registered
Joined
·
11 Posts
Discussion Starter · #16 ·
Mission successful, found it on the harness that plugs up ontop of the valve cover drivers side, wire was rubbed and exsposed a small area where I guess after a certain amount of power went through it shorted.
 

·
Administrator
Joined
·
27,479 Posts
(y)
 
1 - 17 of 17 Posts
Top