The Diesel Stop banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Please help I'm new to a diesel, know my way around a gas engine but this is a different animal as you guys know. But anyway I'm stumped. Had a leak on the non serviceable plug, bought the kit from diesel orings.com removed hpop and revealed then reinstalled. Triple checked all sensor connections but I did break the oil temp sensor. Shouldn't be a big deal right? The truck cranked over on the 2nd attempt after install and filling oil reservoir. Truck now idles like an old hit and miss and has no power. Any help is greatly appreciated. Oh and check engine light is on but I have no way of reading codes.
 

·
Registered
Joined
·
585 Posts
Any time you break open the high pressure oil system, air will always find its way in. Until all the air is purged out of the system, the engine will run rough and you'll see a lot of extra smoke at the tailpipe. The advice you will typically hear is just go drive it - and drive it hard - for 30 minutes to an hour. That will usually clear things up fine.
 

·
Registered
Joined
·
628 Posts
What Greg said. Run it hard. Lots of hard acceleration runs for about 50 miles. Report back if you still have issues after that.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Thanks guys for the quick replies. I did realize it would be hard to start and run less than normal until the air was purged but this was way worse. I couldn't get over 20 mph that is how low the power was. After calming down for a day and checking again I found the problem it was the large blue wire harness clip on the passenger side top of engine apparently got pulled loose. Plugged it back in and all is good now. Thanks again. Sorry for the unneeded post.
 

·
Registered
Joined
·
628 Posts
It happens to all of us at some point.
 
1 - 5 of 5 Posts
Top