The Diesel Stop banner
41 - 60 of 75 Posts

·
Registered
Joined
·
2,446 Posts
Discussion Starter · #42 ·
Thank you JohndieselMan...and welcome to The Diesel Stop!
 

·
Registered
Joined
·
2,446 Posts
Discussion Starter · #43 ·
I've seen this question posted as few times so I thought I would upload an image of what 6.5" rounds look like in the oval front door hole using the available adapter plate. This was my install prior to the build posted earlier in this thread. This is an Infinity component woofer, I mounted the tweeter in the top of the door panel.

 

·
Registered
Joined
·
2,446 Posts
Discussion Starter · #44 ·
I had another thread going helping me diagnose diesel in the coolant but I'll post my progress here and drop the other thread. I decided to buy a used engine and swap it out.

So I flushed the cooling system of the replacement engine sitting on the floor after pulling the new coolers that it came with:

https://youtu.be/JOrY7DUQtio

I pounded plastic fittings into the engine block holes going to the coolers and looped all of the open connections with hoses back to each other, I add boiling water from pots and kettles, about 4 pass thoroughs with water to heat the block then mixed up VC9 in a pail with the last load of water I added then run the engine for a couple hours with an electric motor.

I then put that engine aside to focus on the truck. I removed the engine out the front. It's not an easy job for clearance coming out the front. The issue is trying to clear the oil pan over the cross member while not have the cross over pipe from the exhaust hit the top of the "doghouse" in the firewall. I dropped the oil pan and ended up unbolting the exhaust manifolds from the head, then it was an easy extraction.

I cleaned up the engine bay:

Engine Auto part Vehicle Car Motor vehicle


Then painted it with DOM16

Engine Auto part Vehicle Car Automotive exterior


Now I can go back and reassemble the purchased engine. I need to put the injectors, coolers and intake back on it before I install it.
 

·
Premium Member
Joined
·
3,756 Posts
Nice work on the engine bay up-grade. (painting) looks neat now.
Hope the new donor motor is a good one mate.
 

·
Registered
Joined
·
2,446 Posts
Discussion Starter · #46 ·
Hey Googs, good to hear from you!

You have no idea how stressed I am waiting to run that engine and see if it's good. I've got my money in parts for what I paid for it. In fact, I verified that the new EGR & Oil Cooler are OEM so that combined with the 4 new injectors, 8 GP's and 2 harnesses gives me back the 1600 I paid but the object of the game is a running truck, not a shelf full of parts.

The little bit of metal in the oil filter housing is what has me concerned but I'm going to drop the oil pan and have a look. If all is clean there, hopefully I am good to go.

If not, I guess the heads and new parts will be getting moved to my old engine for now and I will put it back in. It was running great when I removed it other than the diesel in the coolant and the high miles on it.

I'm hoping the little bit of metal might be from a past component failure but I just don't know what it might be that caused it. I checked the coolant, nothing abnormal came out in the flush, in fact it had already been switched over to red coolant. The valleys where the HPOP and Oil cooler mount showed just oil, I couldn't find any traces of anything abnormal anywhere else so hopefully it's minor... dropping the oil pan will be the last check. In hindsight, I wish I had caught the oil stream when I drained it for an oil analysis. I guess I can look at the bearings and journals for wear and heat issues while the pans off but that's about it I suppose.
 

·
Premium Member
Joined
·
3,756 Posts
Yeah that would have me a bit concerned too .
I guess if you don't find anything suspect when you pull the pan you'll be okay Phil, i would pull the bearing caps and have an inspection of the crank.

It's a good thing you've been able to sell off the parts that you don't need after all you have all those parts on the old motor.

Hope she all good for your sake Phil, when do you think you'll hear it running ?
Maybe a youtube video mate?
 

·
Registered
Joined
·
2,446 Posts
Discussion Starter · #49 ·
Thank you, trails2004, I appreciate the props!

I answered the TT light question in your thread, I hope it helps!
 

·
Registered
Joined
·
2,446 Posts
Discussion Starter · #51 ·
Thanks StorminNormandin, with the hours I ended up putting into it, if I charged minimum wage per hour, I'd still be charging probably about 3K for the console... the expression "Don't quit your day job comes to mind"....
 

·
Registered
Joined
·
2,446 Posts
Discussion Starter · #52 ·
A member on here was asking about how to add express up and down on all windows, I did it, so I thought I would post some details here of how.

I picked up a couple of DEI window modules used from a guy that posted them on another site I frequent. I also found a third one from a guy locally. I paid about $20 a piece for them...but used remember.

These modules can be used stand alone to give you express up and down on 2 windows per module. I installed 2 modules for the four doors and I may add the third one later to cover the power sliding rear cab window.

I tied them to my alarm system so when I push a combo of buttons on the remote I can lower all 4 windows about 1" to let heat out in the summer or hold longer and they all power all the way down. Another combination powers the 4 windows all the way up.

Also when you get out and arm the truck, any windows all or partially down go up.

I connected it to the proximity sensor as well so if you walk by the truck too close and the windows are down , the alarm lets out 2 or 3 chirps and the windows go up without any user intervention. Should be worth a you tube video in the Walmart parking lot

I wired them up on the bench:



Most of the connections on this truck could be made right at the drivers side kick panel other than I had to access the one motor on the drivers door.
I then tucked the modules up behind the dash:



I ran a dedicated heavy gauge circuit from the battery to power these modules which are now powering the window motors instead of the factory spaghetti wiring and I can tell you the windows now go up and down twice as fast.
 

·
Registered
Joined
·
280 Posts
Thank you for posting up this information. Looks a lot more intensive to do the window mod than I thought it might be! This rest of your work log is awesome as well! I think for now I'd just like to fix the factory auto-roll down feature on the drivers door. Any idea on how to do that?
 

·
Registered
Joined
·
2,446 Posts
Discussion Starter · #54 ·
I'm not sure about these trucks but some of the Ford products, especially after the battery has been disconnected, develop a memory issue with what all the way down is. The fix for some of them is to power the window all the way down, release for a split second then press the button down again for 3-5 seconds. Let me know if that works.
 

·
Registered
Joined
·
17 Posts
Phil,

Man you have way to much time on your hands! That's some awesome work there buddy! I love the pics at various stages of the process.

Again, great job. Impressive talent.
 

·
Registered
Joined
·
2,446 Posts
Discussion Starter · #56 ·
Thank you Tadpull, yes.......yes I did have a lot of time back then. I don't have that kind of time now but I sure enjoyed it when I could. I think I will make a good retiree when I get there.
 

·
Registered
Joined
·
19 Posts
Wow, that is a lot of work, looks great man!!! Wish I had that level of skill with work and fiberglass fabrication!
 

·
Registered
Joined
·
2,446 Posts
Discussion Starter · #58 ·
Thanks CJS10mm. It was a ton of work and quite mentally therapeutic.

She's under the knife again, I have another project I'm in the middle of right now that I will be posting here hopefully in the next week or so.

BTW, I Love red trucks.... just sayin.. :)
 

·
Registered
Joined
·
2,446 Posts
Discussion Starter · #59 ·
New Project - Full Espar Diesel Fired Heater Install

This is the latest project I have been working on. A couple of weeks ago, I finished installing the newest generation of Espar Coolant engine heater, the Espar Hydronic 3 D5E Water/Engine Heater with box & Easy Start 7 day Timer control unit. It is my understanding that if it’s being installed under the truck, the only way Espar will warrant it is if it’s installed in the box, not open to the elements. As it turned out, the boxed unit made for a great under truck install.

I took it a couple steps further by adding the Espar Blower Control Module to use the OEM HVAC system in the dash to blow heat into the interior plus I added a Thermostat in the cab to control the temperature.

I’ll give some detail here of what was involved to install this into my “07 6.0L .

I may do a separate thread with step by step detail as I have not found anywhere on the net where anyone has detailed an install of this new unit yet. It was just released in January so info was very scarce, I had to figure a lot of it out as I went.

If anyone is really interested in the step by step detail, let me know, I’ll definitely do the more detailed thread then with part numbers etc.

So, the kit I ordered all shipped in one box, this is what was in it:



Here’s the heater unit itself with the box cover removed. The unit with the purple wires going to it is the water pump. On this model heater, the pump is external which is an advantage if you are trying to install the unit behind the front bumper or under the hood, the unit is much smaller than the older ones with the internal pump as the pump can be mounted remotely.



This is the timer/ control unit. It allows for multiple daily or weekly programming of the unit to turn on by itself on a predetermined schedule. Great for commuters that want a warm engine and cab when leaving for and coming home from work. Or the commercial guy that heads out every morning for his run.



This is the bag of hardware as well as the fuel pump :



There are basically 3 wire harnesses to install:

1: Power Harness run to the battery
2: Fuel pump harness which runs from the main unit to the pump mounted on the frame
3: Control unit harness running from the main unit into the cab to the timer/control unit.



This was one of the longest parts of the install for me, most of a Sat and part of a Sun… figuring out how I was going to mount the unit under the truck. I rifled through all of my scrap steel trying various ideas and settled on using a couple of old U-bolts from swapping out the 4” rear end blocks with 2” blocks. I then had to make up spacers & L channel brackets as you can see here. Those shims welded to the tube steel are body shims from an old Pontiac sunfire. It worked perfect. I ended up slinging the U bolts over the top of the frame rail just in front and behind the transfer case skid plate and slid the heater box mounted on the "L" channels up to the frame and tightened down the u-bolt nuts. The angle of the Espar box was absolutely perfect for the angle of the cab floor above it. For service, remove the heater’s 2 exhaust pipe bracket nuts, remove the 2 U bolt nuts closest to the outside of the truck, run the inside 2 nuts down to the bottom of the U-bolts and the heater hangs there low enough to remove the service door off the heater box.





With the heater now tucked up under the truck, I moved onto installing the Timer/ Controller in the cab. By mounting it here, I can remove the dash bezel when I want without touching it and I can open the door to the truck and turn the heater on without getting in.



Next, I was back under the truck again to hang the fuel pump on the frame rail back in front of the passenger side wheel well. The pump must be attached on a 15-45 degree angle. I used an existing hole in the frame to mount it so the total count of holes drilled in the truck to install heater controller and pump is 1 so far, just the hole in the dash for the timer. I also took the small plastic fuel line and ran it through vacuum hose for protection then routed it from the tank to the pump then pump to heater.

 

·
Registered
Joined
·
2,446 Posts
Discussion Starter · #60 · (Edited)
Next up was the main power harness. Normally this harness would route to the engine compartment to the battery but since I am installing Aux batteries behind the back seat, I ran my power cable to the rear of the cab and up in behind the passenger side back seat, again using an existing rubber plug in the cab:



Then using the supplied clamp I clamped the exhaust pipe to the bottom the main heater and routed it out through the bottom of the box:



I mounted the heater up in place and secured the exhaust pipe to the body with supplied clamps, (again using existing holes in cab):



I created a custom mud guard to protect it from road debris off the front passenger side wheel, salt spry etc. I used an old CB antenna L-bracket and another old bracket I found laying around and again, used existing holes in the frame and sheet metal to mount it.



Then onto the most joyous part of the install…. Dropping the fuel tank and installing the fuel pickup:



I then bypassed the fuel pump and used a might vac to pull diesel up through the fuel line to aid initial start up. I don’t know about this new unit but apparently the older units would throw a fault code if you didn’t prime them causing a trip to the dealer to have the unit reset. I wasn’t going to take that chance. (You can see here how the heater is accessible by lowering it down on the u-bolts and removing the door)



Now on to the cooling system plumbing, the heater hose does not come with the kit, one of the few things that's not included. I used regular rubber ¾” hose. I removed the factory piece of hose shown in the pic that runs from the water pump to the heater core and added the Espar heater in series with those 2 connections opened up from the removal of the hose:





I then topped up the coolant, ran the engine then pressure tested the system:



There is still a long way to go, I will continue with this updated asap but got to get some sleep now…. More to come!
 
41 - 60 of 75 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top