The Diesel Stop banner
1 - 19 of 19 Posts

· Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
so I have a 92 with a 97 ps in it.
E40d auto
I'm having transmission issues super slow acceleration and random shifting. Sometimes upshifts while going up a hill. Some times will down shiftat the top of a hill.
Going down the road with consistent pedal it down and up shifts randomly. Not slipping just shifting.
Changed filter and oil. Was clean oil with no chunks in it. Didn't smell burnt.
My tach works oddly.
Reads about 100 at idle and is responsive till about 500 rpms and doesn't go higher even though the truck is reving higher.
Unhooked speed sensor on rear diff to see if it
was that and all it would do is shift to first and then drop into neutral. And go back and forth. Cps is black sensor that was just put in.
Truck has a hard time with hills. Not hauling anything I lost speed quickly even if it does down shift sometimes. No idea what is causing this.
New to site and first diesel.
 

· Super Moderator
Joined
·
9,138 Posts
The tach has to work properly for the trans to shift properly.
 

· Super Moderator
Joined
·
9,078 Posts
If the engine is running fine then I would say that the CPS is fine also. It does a lot more than just provide a signal for the tach. The PCM gets a info from it as to when to fire the injectors, so I would say that the PCM is fine also if the engine runs fine.

There could be something in the PCM but I have no idea of the programming to run the transmission or just what input it needs. I would guess that the PSOM in the dash would be one part that sends info to the PCM and it gets its info from the VSS
 

· Super Moderator
Joined
·
9,078 Posts
Speed sensor.

That's the problem with these trucks, if you don't understand the electronics you are in some brown stuff up to your eyes. Most of us just guess a lot and sometimes we get it right and sometimes it goes the other direction.

But it is my understanding that the VSS gives input to the PCM which is programmed to accept the data and then determine the shifting strategy. But I could be wrong.

As for the CPS, the tach does gets its info from it but it goes through the PCM first. But I am not sure if two things such as your problem would happen all at once or contribute to both.

And without looking at wiring diagrams it is hard to tell just where the wiring for the VSS goes first. The PSOM which operates the speedometer or the PCM which uses it's input for a few other things.

You may see if you can find a VSS out of a working truck and swap it into yours just for giggles and see what happens. I know that when mine was not seated completely I had all kinds of problems with the speedometer and cruse from 60mph and up. Below 60 and everything was fine.

Just trying to give you some straws to grab at..
 

· Super Moderator
Joined
·
9,138 Posts
You still need to get the tach working correctly for the trans to work correctly. Since you changed the sensor it is likely that the wiring from the sensor to the PCM is the issue.
 

· Super Moderator
Joined
·
9,138 Posts
Are you looking at the wires, or electrically checking the wires? Just looking is useless.
 

· Registered
Joined
·
2,549 Posts
Read this caption:

(phone app link)


These are also relevant to the original '92 wiring:

157757


157758
 
1 - 19 of 19 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top