The Diesel Stop banner
1 - 20 of 45 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter · #1 · (Edited)
Hi guys,

Yesterday my truck get towed at my home. Went to the grocery and when i was in the parking lot, the engine stall before i shut it down by myself. When I crank the truck I only get 100-200 PSI of oil on my HPOP gauge. My fuel is OK I got 65 PSI. There are no leak of oil or fuel.

My HPOP is a T-500 and have 1500 miles on it. The LPOP is new, the HPOP reservoir is full of oil. I think that the problem could be the IPR but I need confirmation before I buy this unit.

What do you think guys ?

THanks, Luc
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #3 ·

·
Registered
Joined
·
2,846 Posts
id say the icp or ipr too.


try unplugging the icp and see if its starts.


the ipr could be stuck open not allowing it to build pressure.


also you could have blown an oring on an injector.
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #5 ·
id say the icp or ipr too.


try unplugging the icp and see if its starts.


the ipr could be stuck open not allowing it to build pressure.


also you could have blown an oring on an injector.
I've unplugged my ICP with NO START. All of my injector oring have 1500 miles on it. Could the hex nut on the back of the IPR can qet loose and the unit stop working ? That's the only thing i've didn't check.
 

·
Premium Member
Joined
·
15,105 Posts

·
Registered
Joined
·
2,846 Posts
Oem injector Orings or aftermarket?
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #8 ·

·
Registered
Joined
·
64 Posts
Discussion Starter · #9 ·
Hi guys,

I've installed my new IPR today and still didn't have pressure on my HPOP gauge. Any ideas ?
 

·
Premium Member
Joined
·
15,105 Posts
Pull the HPOP front bolt cover and verify the nut is on tight. Did you install the HPOP?


Sent from AutoGuide.com Free App
 

·
Premium Member
Joined
·
15,105 Posts
Right. I'm asking who installed it and for you to check the front bolt. If it wasn't torqued properly, there's a chance the bolt is loose and the HPOP isn't actually turning.


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #12 ·
Oh sorry, i've installed it. I'll check if the gear is turning while i crank the engine. Thanks !
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #14 ·
That won't do it. You need to check the torque. If loose it can not turn at all or slip under load. You need to hold the crank with a socket and ratchet.
Ok thanks ! I'll give you news soon if it works!
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #15 ·
Ok so the bolt on the HPOP gear was ok, torqued to 95 lbs/ft. I'm really confused now, i've checked all fuses, i have my hpop reservoir full of oil, my ipr is brand new, i've disconnected my icp, i've checked for oil leak (hpop hose, oil cap, HPx fitting...), my batteries are fully charged and my truck crank but don't start and don't seem to want to start !!! I still didn't have pressure on my HPOP gauge ! Any ideas guys ??? Thanks!!
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #16 ·
And if it could help, the last 30 seconds my truck run was like that : the engine seem to run on half of it's cylinder and had absolutly no power then 30 sec later it shut down but itself... (Maybe a lost of oil in the hpop lines)
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #17 ·
I've bypassed the ICP directly on the 12V battery and still no press...
 

·
Premium Member
Joined
·
15,105 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter · #19 ·
Yes !
 

·
Registered
Joined
·
514 Posts
Just wanted to know what you found out on getting your truck running. Was it the hpop went bad?


Sent from AutoGuide.com Free App
 
1 - 20 of 45 Posts
Top