The Diesel Stop banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Looking for some help with an ongoing issue, on cold start, I get a up and down rev'ing, then usually leads to a few stalls, has stalled once while driving when coming to a stop, almost seemed like it idled to low, but not sure, like I said, does it on start up too, didn't do this before without a tuner, had all new premium injectors and c-cups installed, cold air intake, plugs were above 90%, please help...
 

·
Registered
Joined
·
4,686 Posts
ROMPS, What are you using for oil? The 7.3 can be oil sensitive. Simple things to do are change to a 5-40 synthetic and see if that helps, pull the programer/chip and see if it gets better.
DENNY
 

·
Registered
Joined
·
1,615 Posts
OP didn't mention which tuner, but I'll get romps starting a cold soaked engine if I am in any of the higher HP tunes. So what I do now is start on my 1000 rpm idle tune, which is probably just the stock tune as the base. It starts right up and after a minute or 2, switch to another tune. I believe it is an injection timing issue...give it a shot.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Delo 15/40, switching to another tune usually makes it stall, and even after warming up stalls a lot, replaced the ICP switch and pigtail
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
ended up being the IPR switch, fires right up, no stalling or up&down rev in case anyone else runs into this prob
 
1 - 5 of 5 Posts
Top