The Diesel Stop banner
1 - 4 of 4 Posts

·
Registered
Joined
·
388 Posts
Discussion Starter · #1 ·
I got a 2001 excursion with the good old 7.3 PSD engine. The dome lights didn't work, but I figured it was a fuse and good a good deal so I didn't worry too much about it.


Well turns out that there was something more wrong. All the fuses seem good - someone had unplugged or cut the wires to the dome lights (they took a knife to the power distribution ribbon in the overhead console that I think can only be replaced by buying a new overhead console, grrr).


I am pretty certain that the problem is not the door ajar sensors. The locks stick (I hear the actuators, but the locks don't always physically move), I figured things were dusty, so I loaded the latches with WD40, opened and closed each door a few times, and there was no change. Also, the door ajar light always comes on when a door is opened, but is never on when I don't expect it (except for a few occasions where the rear doors aren't shut all the way, but that is easy to fix by opening and closing it). Any way, as long as the line that drives the door ajar light is the same one that drives the dome light turn-off, then that sensor is not the problem.


It has an aftermarket radio that I did not wire in. It turns on and off with the key (it doesn't stay on in the normal case when you drive, stop, and leave the doors closed), but it may have been wired that way so I don't think it's a good test.


I've tried disconnecting the door sensor harness, but was only able to easily access the one at the passenger side kick panel. Disconnecting and reconnecting it had no effect. But when it is connected, the door ajar light works as expected with respect to those doors.


The accessory delay fuse is good. The accessory delay relay appears to be working fine too, and clicks as expected. I need to perform a real test on it though.


Also, the lights on the window/lock controls on the armrest work as expected. That is, they turn on with the vehicle and stay on if it is turned off with the doors closed, then turn off when a door is opened.


I don't want to put in a manual dome light override switch. My goal is to fix it so it works with the doors.


Can anyone suggest what I could check next? Is this even the right forum? I'm used to posting in the 7.3 L PSD engine section. >:)
 

·
Registered
Joined
·
859 Posts
More WD40 and cycle the door and the locks. There is a write up here or with the superduties that talks a lot about this. It took a couple of days for mine to work right but now, 2 years later, all is still good.
 

·
Registered
Joined
·
388 Posts
Discussion Starter · #3 ·
More WD40 and cycle the door and the locks. There is a write up here or with the superduties that talks a lot about this. It took a couple of days for mine to work right but now, 2 years later, all is still good.
If that were the problem, wouldn't the door ajar light be on too?
 

·
Registered
Joined
·
388 Posts
Discussion Starter · #4 ·
Figured it out last night. The problem was the interior light relay (the small one on the top on a 2001). Replacing that fixed all the lights.
 
1 - 4 of 4 Posts
Top