The Diesel Stop banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I picked up this truck with 257k on it. Guy said tranny was rebuilt but who knows. Had a new front seal put in which fixed leak. It stalls in reverse and drive. Engine light doesnt stay on and seems only come on when you are driving it. Truck starts off ok and shifts through gears sometimes a little rough. After few miles it doesnt seem to want to shift so have to start in 2 but still goofy. In drive its like the truck doesnt want to get going. I can let truck sit overnight and it will do same thing. Transmission sounds like it is sizziling underneith. Is this a possible solenoid issue? I didnt do the tranny so i was going to do a filter and solenoid change seeming wasnt to expensive. Any ideas? This is the 4r100 tranny
 

·
Super Moderator
Joined
·
11,744 Posts
If you want to randomly replace parts, change the solenoids. It would be MUCH better to read the codes (even if the lights are not on) to see what's wrong before just changing parts.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
I ran a scanner on it...codes p0603, internal control module, p1316 idm, p1783 transmission overtemp, p0717 and p0715 turbine speed signal, p0541 manifold heater all came up. My goodness where to start
 

·
Super Moderator
Joined
·
11,744 Posts
Start with the turbine speed sensor. It could be a bad turbine speed sensor, but even more likely is a problem with the wires between the PCM and the turbine speed sensor.
 

·
Super Moderator
Joined
·
11,744 Posts
It is possible.
 
1 - 6 of 6 Posts
Top