The Diesel Stop banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I've got a 2002 f250 7.3
2wd crew cab

When idle it does great when I drive down the road initially it does ok then after about 20 to 30 mph it acts like a bucking bronco and shakes pretty bad when I slam on the pedal it takes off ok and does fine
When I idle it runs fine
When I drive at a consistent speed it shutters and bucks back and forth but when the engine is warmed up it drives fine minor shakes but seems fairly normal

Mechanic said fuel pump and filter did that nothing changed now he wants to do injectors I saw some people in other posts saying tps , pps but not sure any suggestions or ideas ? I bought a pedal assembly to try either way but any other ideas?
 

·
Registered
2000 Ford F-250 flatbed 7.3L power stroke with a 4 way chip and 6 spd manual tranny. 285/75/16 A/T
Joined
·
111 Posts
How do the motor and tranny mounts look on it cause they might be broke or tires being bubble/buckled thats all that was wong with my buddies was the tranny mounts and left side motor mounts were out.. Coyt
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
How do the motor and tranny mounts look on it cause they might be broke or tires being bubble/buckled thats all that was wong with my buddies was the tranny mounts and left side motor mounts were out.. Coyt
But once its warmed up it runs fine at all speeds?
 

·
Super Moderator
Joined
·
26,160 Posts
Don't let your mechanic talk you into replacing injectors. Likely all that will do is drain your wallet.
How many miles on the engine? If 250k plus, you might need an injector shim kit, but injectors should be OK.

Check that the tin nut holding the coil on your IPR is tight. If loose, it cause running issues. Also possible that your Accelerator Pedal Position Sensor is bad, but if its OK after warms up that should rule it out.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Don't let your mechanic talk you into replacing injectors. Likely all that will do is drain your wallet.
How many miles on the engine? If 250k plus, you might need an injector shim kit, but injectors should be OK.

Check that the tin nut holding the coil on your IPR is tight. If loose, it cause running issues. Also possible that your Accelerator Pedal Position Sensor is bad, but if its OK after warms up that should rule it out.
Pedal assembly didnt fix it thought it did but issues kicked in at 50mph when I took it out,
I'll have to check that when I get home, I have no codes on the dash but cant check obd port doesnt work :/

But i will check that
 
1 - 5 of 5 Posts
Top