The Diesel Stop banner
1 - 5 of 5 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 ·
I have an issue when engine is cold.It starts right up,runs rough at idle,when you go to accelerate it stumbles and blows black smoke and acts like it is flooded.This happens for less than a minute,then runs fine,even on multiple restarts that same day! ROY.
 

·
Registered
Joined
·
7 Posts
I have an issue when engine is cold.It starts right up,runs rough at idle,when you go to accelerate it stumbles and blows black smoke and acts like it is flooded.This happens for less than a minute,then runs fine,even on multiple restarts that same day! ROY.
If it runs fine once hits operating temp don't worry about it, diesels don't like the cold man.
 

·
Registered
Joined
·
2,846 Posts
There is definitely an issue.

Low oil/old oil or too thick of oil.

Bad Icp sensor. Unplug connector if there is oil inside it has failed.

Sticking ipr valve.

It was 20 here last night mine started smooth like it was 80 outside. Didn't plug it in either and hadn't driven it in a few days.
 

·
Premium Member
Joined
·
2,197 Posts
^^^ agree whit blue, here around 15* the last 3 to 4 days and never ad the truck plug in, still start like a charm no smoke


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #5 · (Edited)
Isuue when Cold

Has not been that cold here,have had truck for over 5 years and 75,000 miles,it could do it when it is 100+ outside!! I will check those items,the oil was just changed by FORD less than 20 miles,was doing it with old oil too!! THANK YOU for the tips!! ROY.
 
1 - 5 of 5 Posts
Top