The Diesel Stop banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
hi guys i have a 2003 ford 6.0 and the hpop failed the other day. put a new hpop in and the truck rain great for 20 min. when it died my scanner was only showing 100 psi out of the hpop. took it apart again and did a air test on it and air is coming out the turbo oil drain tube. where could the leek be coming from?
 

·
Registered
Joined
·
5,125 Posts
How do you know it was the HPOP that failed? I'm not saying that a reman HPOP that was bad basically out of the box is unheard of, but it seems you changed a major part with no improvement. That would send me on the hunt to be 100% sure it was indeed the HPOP. '03 are notorious for ICP and ICP harness issues. I'd be very sure that the electrical side of things is right before throwing another HPOP at it. If you reused the IPR, that's another possible culprit.
 

·
Registered
Joined
·
5,448 Posts
A common mistake I see happen with this style pump is that people fail to inspect and replace the o-ring on top of the discharge tube that seals the tube to the pump cover. They do erode and commonly leak. Also, it is senseless to simply remove the two bolts that secure the discharge tube to the pump and just swing it out of the way and toss a new pump in without disconnecting and removing the tube to inspect the seal in the quick connect fitting. I cant tell you how many times I have seen that play out. It sucks to have to go back in or pay someone to figure out your mistake. Not sayin that is the case here... just sayin I have seen it more than once.
 
1 - 5 of 5 Posts
Top