The Diesel Stop banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Ran fine when I got her, replaced HPOP and IPR and camshaft and crankshaft sensors and bad injector, and ICP and pigtail and now won’t crank over. It will start on starting fluid sometimes but have to hold foot to the pedal to keep it running or it will just shut off. I don’t know what else it could be.
 

·
Registered
Joined
·
504 Posts
Your post doesn't make sense. If your truck really truly "won't crank over" then you could spray enough ether in it to make it float to Jupiter and it would never run. Please explain more clearly what is happening. And stop feeding it ether until you get the problem(s) resolved.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Your post doesn't make sense. If your truck really truly "won't crank over" then you could spray enough ether in it to make it float to Jupiter and it would never run. Please explain more clearly what is happening. And stop feeding it ether until you get the problem(s) resolved.
Got the truck it ran fine, had code for a misfire and I replaced one the one injector, code disappeared. Truck stopped running so I replaced the high pressure oil pump and IPR. And started right up, a few days later the issue of starting would only start when cold. I was told to change ICP and I did that and it ran fine for a couple days now it won’t start. If that makes any more sense
 

·
Registered
Joined
·
5,505 Posts
What are you using to retrieve the one injector code? Will it retrieve engine parameters also?

It seems that a number of parts are being changed on pure guess work
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
What are you using to retrieve the one injector code? Will it retrieve engine parameters also?

It seems that a number of parts are being changed on pure guess work
It’s code reader can’t remember the name off top my head it tunes and what not, but no I replaced when the codes appeared. And now there is no codes after Everything I replaced
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
It’s code reader can’t remember the name off top my head it tunes and what not, but no I replaced when the codes appeared. And now there is no codes after Everything I replaced
And I have a app and piece that plugs into my tablet to read the codes
 

·
Registered
Joined
·
5,505 Posts
Some code readers do not do a thorough job. You may have one of those. Thorough code readers are a necessity with the 6.0L.

If you are interested, ForSCan is a very good code reader. Torque Pro isn't bad, but not as good as ForScan.

Without knowing what you have, all we can do on this side of the screen is guess.

Read up on "hot, no-start" for the 6.0L. Maybe that is your issue (just another guess).

Readings (when cranking) needed to confirm (available on even inexpensive scan tools):
FICM Sync
Cam/Crank sync
Injector Pulse width
cranking rpms
ICP pressure, psi
ICP volts
IPR % duty cycle
V-reference voltage
FICM MPower
FICM VPower
FICM LPower
 
1 - 7 of 7 Posts
Top