The Diesel Stop banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
My 2005 F250 with a powerstroke 6.0L is currently tuned using a Hypertech max energy. I am using stage 3 and get great performance. The trouble is after about a week the truck seems to lose the tune. The performance goes back to almost stock and gas milage goes down also. If I reprogram the truck it acts like it should with stage 3 and after about a week it reverts to the sluggishness again. DTC's showing p0401 which is EGR related but I have an EGR delete on the truck. Also showing p0671 which is glow plug issue but I dont think this would effect the performance after warm.

Any suggestions? I called Hypertech and they said they have never heard of these symptoms before.
 

·
Registered
Joined
·
1,344 Posts
Once the PCM is flashed, it will not revert back to stock. When you retune the truck you are not changing anything since the tune is already in place. What is happening though is that you are causing the PCM to enter into a learn mode. The next time it happens try pulling the number 10 fuse in the under hood fuse panel for twenty seconds and see if that makes it act like it does when you attempt to retune it, since that will also put the PCM into a relearn mode. There appears to be something in the system that is causing the power loss. It will require a scan tool capable of reading sensor outputs. The P0401 is being set by not having the EGR in the system. When the EGR is commanded to open on your truck the PCM looks for a temperature increase from the intake manifold temperature sensor. Since there is no EGR, no EGR flow, therefore no temperature increase, the P0401 code is set. It is also possible that that may be the issue. Anytime a EGR delete is done on an 05 or later truck, it should be programmed with a EGR delete tune.
 
1 - 2 of 2 Posts
Top