The Diesel Stop banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Just hooked up our trailer to the new 06 ford f350 equpied with TBC, the brakes work fine, the lights work fine but we keep getting an error message in the display panel(on the truck) the trailer is disconnected, then it goes away then it comes back on. the little trailer on the TBC goes from green to red then back to green and keeps repeating it over and over.

anyone else have any problems with the TBC on the fords?

Thanks
Mike
 

·
Registered
Joined
·
130 Posts
No problems with mine. Sounds almost like an intermittent wire connection or ground if it goes away and comes back. Any other trailers you could test with?
 

·
Registered
Joined
·
772 Posts
I think Cartman is on the right track and personally suspect a ground problem. A quick and dirty way to verify or dismiss this is to hook a jumper cable between the truck and trailer frames and see if the problem goes away. Good luck.
 

·
Registered
Joined
·
353 Posts
I had the same problem on a 05 with the ford brakes. Ford put a new brake controller in( this was the first that they worked on and thought it had to be the truck and not the trailer) but it still did it, not as bad though for some reason. SO i traced all the wires on my trailer and found a small break in a wire going to the brakes, fixed it and havent had a problem with that trailer since.

But our other trailer which is brand new, gives us some problems every now and then. It will say trailer disconnect also sometimes and we think it might be in the actually plug on the trailer.
Both times my truck(05 without Ford brakes) had no problems what so ever with either trailer. I have a cheap prodigy controller in it i think.

So check the wires on the trailer mostly the grounds and wires going to the brakes.
 

·
Registered
Joined
·
3,959 Posts
make sure the ground wire is grounded to the frame of the trailer.
 

·
Registered
Joined
·
2,584 Posts
I was having a hell of a time with a female friend of mines new towboss and her 6 horse sundowner. It was doing the same thing you describe. Finally after going over every inch of the trailer wiring from stem to stern and underneath.

I cut the plastic 6 way plug off the trailer and replaced it with a new pollak (sp) metal 6 pin and that solved all the trailer disconnect problems. Also I spread the pins of the six way on the truck side VERY slightly to make better electrical contact.
 

·
Registered
Joined
·
278 Posts
If your trailer has hydraulic brakes that could be the problem. It seem's that the ford brake controler doesn't like hydraulic brake's on trailers. If that's the problem I can give you the name of the brake company that has the fix.
 

·
Registered
Joined
·
219 Posts
geez just take it back to the dealership ,you oughta have a warranty,

its an 06 man /ubbthreads/images/graemlins/shrug.gif
 

·
Registered
Joined
·
1 Posts
I get a TBC default at start up and the trailer brakes only work manually even after reset.
I changed the connector because it was corroded and then changed the brake module. I checked all of the connections I can find and they all seem to be in good shape.
I haul a 5th wheel trailer and sure don't need the trouble of applying the trailer brake manually.
Thanks...
 
1 - 9 of 9 Posts
Top