The Diesel Stop banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi guys I am new to this forum and in need of some help. Thank you too anyone who does help. My truck is acting really strange and idk what to do I recently had a code for the EBPS I cleaned it and my check engine light went away. Anyway the current issue is the truck battery drains really fast. I jump the truck and it will run on its own for a while then I go to start it again and it try's to start and then the batteries just die. I can hear a weird clicking noise near the radio and the CD player says cd error. the battery light on the dash is also on along with another light that is a car with a lock on it. Once I get the truck started it idles pretty well and then it starts to stumble a little bit and then will go back to normal. Every now and then I hear a strange buzz coming out of the egr valve also. White smoke is pouring out of the exhaust. The coolant has not drained at all. The pictures attached are with the truck hooked up to a jeep with jumper cables in case you are wondering why the batteries say 13.6 volts. I have no idea what is wrong with the truck I've only had it for 3 months I bought it used with 183,000 miles and I probably drove 800 completely fine. There is also some type of oil leak on the driver side when I go under the truck I rub my finger on the engine and find oil on it it goes pretty high up. Please any help would be much appreciated once again thanks to anyone who helps me out!!!-
Seth
 

Attachments

·
Registered
Joined
·
212 Posts
your alternator(s) are toast, and they likely took your batteries with them, or, your batteries are toast, and they took the alternator(s) with them... these things ought to be replaced together... and that is what it sounds like you need to do... I wouldn't run it much until you're fixed, because those things can do strange things when electricity is an issue.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Thanks for the response I recently took out my alternator and had it checked and it was fine but my batteries were toast so I got new ones. As of right now there are two things first the electrical side the CD player clicks every time I open the door and then says cd error. Then the doors don't lock either. Also I hear a weird electrical buzzing noise coming from the EGR valve or one of the sensors connected to it. So let's say I start the truck up its a cold start...white smoke doesn't pour out but it's coming out I rev the engine and more a larger cloud comes out. So I drive for 5-10 minutes all of the sudden no more white smoke the. I sit let her idle for a while no white smoke. Then I drive a lil longer and then stop and let her idle for about 15 minutes all of a sudden the engine starts sounding weird and running rough and the white smoke is coming out pretty good. Now here's the weird part. I turn it on and off real quick and it starts up perfectly fine with no white smoke then I driver home and parked it. So I feel like it is some sort of other electrical issue with buzzing of the EGR valve and how the white smoke and engine running rough stop right when I turned it off and on. Also the EGR and CAT never finish their readiness test.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Would I know if it's in active regen? I hit settings and reset and it never says "cleaning exhaust system".
 
1 - 5 of 5 Posts
Top