The Diesel Stop banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Good evening everyone... working on a 08 F250 that has a couple of transmission problems. Trans slipping and no reverse
The codes i have are p0766 and p2703. I ordered a new filter (atp b359) and oil Mercon SP.anyone ever had same problems

1. While streaming live data... when I select reverse should Forscan show me that im in reverse???.. it does not it just shows im in 1

2. I did the full TCM reset..while driving that same day the codes did not reappear. the next day the codes came back.

3. Is there anyone willing to review my driving log. If so pm me your email adress i will send it.

4. Anyone solved trans problems with replacing filter and put in fresh oil??

5. Today i drove around a bit live streaming before deleting the code... with the codes still there it did not give me any faults on thr solenoids
 

·
Super Moderator
Joined
·
11,618 Posts
Curacaoz28 said:
1. While streaming live data... when I select reverse should Forscan show me that im in reverse???.. it does not it just shows im in 1
That's correct. It does not show reverse.

Curacaoz28 said:
2. I did the full TCM reset..while driving that same day the codes did not reappear. the next day the codes came back.
Then shift solenoid D is still bad.

Curacaoz28 said:
4. Ever solved trans problems with replacing filter and put in fresh oil??
Never. Not even once.

Curacaoz28 said:
5. Today i drove around a bit live streaming before deleting the code... with the codes still there it did not give me any faults on thr solenoids
If the code is there the solenoid is stuck.

I think the next step is to replace shift solenoid D and see if the problem is gone.
 
1 - 2 of 2 Posts
Top