The Diesel Stop banner

1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Recently my 6.9 has had a drop in oil pressure, at start when cold oil pressure goes to about 45 at idle, but once its warmed up the lowest ive seen it go is 6 psi. I have read around a bunch and still am not sure I just need a confirmation that 6 PSI on aftermarket gauge is SAFE for my motor. I am going to see what I can do about the oil pressure regulator valve but if that is not the culprit I don't know what I should do
 

·
Premium Member
Joined
·
14,489 Posts
One thing to consider is your oil pressure sending unit. I have an autometer setup on mine. I noticed my pressures dropping as well. I always had 50 psi cold / 25 psi hot. Then, I noticed those numbers sliding and started worrying about bearing clearances, oil pump issues, the regulator valve, etc. I even changed my oil pump - with no change - before remembering to double-check my gauge. Yep - you guessed it - bad sending unit. Now my pressures are right back where they were.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
One thing to consider is your oil pressure sending unit. I have an autometer setup on mine. I noticed my pressures dropping as well. I always had 50 psi cold / 25 psi hot. Then, I noticed those numbers sliding and started worrying about bearing clearances, oil pump issues, the regulator valve, etc. I even changed my oil pump - with no change - before remembering to double-check my gauge. Yep - you guessed it - bad sending unit. Now my pressures are right back where they were.
I just installed a new gauge that came with the sender, and at warm idle i only get 6 psi. I am going to take a look at the oil pressure regulator valve tonight and see if it's stuck open. But once i have assured that, my question is what is the minimum psi these motors should idle when they are warm
 
1 - 3 of 3 Posts
Top