The Diesel Stop banner
1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
OK so I have my 86 f250 6.9 idi I've already posted once with a similar problem after reading replies I changed from my lift pump to an electric fuel pump (personal preference I guess) ran fine for a day or so, back to the same problem only worse. It has a very hard start in the mornings after getting warm it usually fires right up the rest of the day, this isn't a new problem just throwing it out there. It has a very rough idle and shakes to the point that I'm surprised the cab hasn't shaken off the truck! When running it is very sporatic and surges almost like it wants to just run top speed! Whenever I shift(standard) it feels like it gives itself way more gas than I tell it to and then runs very rough and dies at idle whenever I come to a stop. I have chacked and I can't seem to find air in the lines I used some clear gas line to look for air bubbles if there is a better way to check feel free to tell me how. Now it won't start at all... Any ideas? I'll try to get a video later if I can get it started fuel filter? IP? Injectors? Fuel screens? No idea where to start!! I'm not new to working on cars but this one has me stumped please help.
 

·
Registered
Joined
·
3,553 Posts
[quote fuel filter? IP? Injectors? Fuel screens? ][/quote]

All of the above.

Did you bypass the engine lift pump? or are you pumping thru it?

What fuel pressure do you have after the filter?

What electric FP are you using?

Do you have more than a 1/4 tank of fuel?

Videos don't help, already know it's running ruff.
 
1 - 2 of 2 Posts
Top