The Diesel Stop banner

1 - 8 of 8 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter #1
late 99 SD with 225k miles, manual trans. Truck is well maintained, with minimal issues.
Driving yesteday just fine, them truck started to run real rough outta no where. pulled over, it eventually stalled, no restart. No CEL, Good fuel flow out of drain valve w/ key in run (tank 1/4 full), oil level good.
Put in new fuel filter, pulled chip, unhooked ICP sensor with no change. Truck seems to start if let set for 20+ min and will again run rough then stall, almost like not getting fuel? Its 20*F +/- here in SE MI, but ran fine on same fuel last week when it was -15*F. Not one to just throw parts at a vehicle, prefer to troubleshoot and diagnose properly. Any thoughts are much appreciated
 

·
Registered
Joined
·
74 Posts
Discussion Starter #2
Within past couple years ive replaced ICP and CPS. leaning towards bad IPR or insufficient fuel PSI? not sure or port to verify fuel psi?
 

·
Registered
Joined
·
4,736 Posts
If you were on a hill I would suspect a bad foot in the fuel tank. You could have clogged screens in the tank, or a fuel pump going bad. If you can put a pressure gauge on the fuel system and see what the pressure does as it starts to run rough that would help figure it out.
DENNY
 

·
Super Moderator
Joined
·
25,427 Posts
Maybe a heat issue with the coil on the IPR, although that should throw a code.

Clogged in-tank screens like Denny suggested is a real possibility.

Check fuel pressure at the back of the filter housing. You'll need an SAE o-ring to pipe thread fitting.
 

·
Registered
Joined
·
74 Posts
Discussion Starter #5
I will hook up pressure guage and see what i got. what kind of numbers am i looking for?
 

·
Registered
Joined
·
998 Posts
Not sure if your stock or not, but put some fuel in it. 1/4 tank, and your mileage are good indicators your 1/4 tank bypass valve is stuck open or fallen off, meaning every time you hit a 1/4 tank it will suck in air. They usually go around your mileage.
 

·
Registered
Joined
·
74 Posts
Discussion Starter #7
Couldnt get the fittings i needed to plumb gauge into fuel bowl today. unhooked fuel line at pump outlet. turn key to run, pump runs but no fuel, just sounds like its sucking air. Guess im dropping the tank tomorrow. Thanks for the help and assistance, it appreciated
 

·
Registered
Joined
·
998 Posts
Or keep it above 1/4 tank until you want to do the job. I pull the box, its easier in my opinion.
 
1 - 8 of 8 Posts
Top