The Diesel Stop banner

1 - 7 of 7 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
i dont know if this is the correct place to ask this question . if its not correct i apologize in advance

here is the issue. used motor installed and when going to start i hear a clicking noise from the glow plug relay. pulled out glow plugs
#1 cylinder - glow plug tip broken
#2 cylinder - glow plug tip broken
#3 cylinder - tip melted
#4 cylinder - glow plug in good condition Ohm 0.4
#5 cylinder - glow plug all in one but ohm 15.35
#6 cylinder - tip broken
#7 cylinder - tip broken
#8 cylinder - all in one . ohms 1.5

battery terminals not looking good so replaced all 4 . now waiting to replaced all 8 glow plugs .
my question is will bad glow plus cause NO CRANK NO START condition ? or should the starter turn on?

please advice ..
 

Attachments

·
Registered
Joined
·
11 Posts
Bad glow plugs won't cause a no-crank unless chunks of broken glow plug have blocked the piston. I would turn it over by hand several revolutions to demonstrate nothing is blocking rotation.

If there is something blocking, I don't know if there is a way to avoid taking the heads off.

tom
 

·
Registered
Joined
·
183 Posts
You can bar the engine over to make sure there is not a tip on top of the piston. If it bars over easy then it is time to check the starting system. Make sure batteries are charged. Check and clean all connection as needed. You can try cranking over at the starter relay on the right fender right behind the battery , Little terminal to battery should crank . Next starter is probably bad, Having a parts store do a bench is a waste of time and proves nothing with a diesel starter, they need to be load tested , which most places can't do.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
thank you guys for the info. i found out the issue was the Rpm sensor (on top of the IP) was too tight. after loosning it it turned just fine . thank you all
 

·
Registered
Joined
·
2 Posts
i dont know if this is the correct place to ask this question . if its not correct i apologize in advance. I am having a wiring issue wires have been cut but they have been pliced before and the colors don't match needing help to get this thing going again
 

·
Registered
Joined
·
1,664 Posts
What circuits are you working on? There isn't very much information there. It might also be a good idea to start your own thread, it'll get seen by a lot more people. When you do that put your truck's model, and year along with any after market additions it has in your signature, so we can see what you have questions about.
 
1 - 7 of 7 Posts
Top