The Diesel Stop banner

401 - 410 of 410 Posts

·
Registered
Joined
·
141 Posts
chocks fit snug on all wires except gauge wires wrapped each with tape than chocked.not radio shack ordered from amazon one pack are wellcn the other is lcstation. no pictures. first echlin cps wires were not choked but ran wipers on intermediate spraying with water all was good drove truck that when it stumbled. returned it ordered chocks .installed chocks and echlin cps drove truck didn't notice any stumble got on interstate at 2000 rpm it stumbled came back to shop added more chocks same thing.cps wires and plug on truck are fine.looking and thinking at it last night i have transmission temp gauge ground wire hooked to pcm/wiper ground but all are choked. also when i ohm cps it was 60k.didn't put 50 miles on either one. thanks
 

·
Registered
Joined
·
141 Posts
no second cps i didn't test wipers
 

·
Registered
Joined
·
141 Posts
yes on gauges aftermarket radio all ready put ford cps back in truck runs fine no engine was not wet. all ready took second ecklin cps back
 

·
Premium Member
Joined
·
7,913 Posts
Discussion Starter #406
I think your radio or other than stock equipment is the overpowering source. Stereos are know for interference.
Sorry you have struggled. I know how these things can be frustrating.
If you desire to retry in future, you will want to pull the fuse on each aftermarket item one at a time.
 

·
Registered
Joined
·
141 Posts
ok will try again this spring. also guy at napa said only two in stock said they don't sell.did echlin update cps and I got old one just thinking but thanks so much for you'r time and help will keep u informed been reading this form alot before joining thanks to everyone on it
 

·
Premium Member
Joined
·
7,913 Posts
Discussion Starter #408
Thanks for joining The Diesel Stop.
It can be tricky with aftermarket items on truck but I feel that you will think it was worth it once you get it squared away.
 

·
Premium Member
Joined
·
3,753 Posts
ok will try again this spring. also guy at napa said only two in stock said they don't sell.did echlin update cps and I got old one just thinking but thanks so much for you'r time and help will keep u informed been reading this form alot before joining thanks to everyone on it
Hey stumpman, I have electronic , aftermarket things all over my truck. (maybe the one of the biggest aftermarket accessorized trucks in the land)
I would do as Nick has suggested and choke the ground wires all over the truck, then start with all the aftermarket gear you have , I fitted choke's on Hid's, CPS harness, Tuner harness, wiper motor, Radio/CD, Amp , everything that can interfere with the PCM and the electrics on your truck, it's a process of elimination and can take a long time and make you a little mad, but you will get there.
 

·
Registered
Joined
·
895 Posts
Hey stumpman, I have electronic , aftermarket things all over my truck. (maybe the one of the biggest aftermarket accessorized trucks in the land).

In the free world. It takes longer get through the pilot's checklist before take off in your truck than it takes to send a rocket ship to the ISS. Only your truck is faster, which makes up for the gadget checking time. >:)


Back to stumpman's issue (nice choice in user name, as we all seem to be stumped... except for Nick), and the overall issue of EMI effecting the CMP sensor data feed... Whenever "PCM Ground" is said, what PCM ground is being talked about?


There's at least 9 separate ground circuits in the PCM, and they don't all ground to the same location. For example, PCM ground pin 33 grounds to Ground 300, which is by the left hand kick panel below the E Brake (not for you Googs).


On the other hand, PCM ground pins 61, 24, 23, 103, 76, 77, and 3 are combined at Splice 106, which eventually leads to grounds 101 or 102, model year and diagram depending. Ground 101 is by the driver's side fender near the fuse box. Ground 102 is on the opposite side of the truck at the passenger battery area.


PCM pin #25 is yet another ground. Pin 25 ground routes to Splice 102, and THAT's the mofo where the windshield wiper motor is also grounded, along with a bunch of other components. Splice 102 leads to Ground 100, which is on the cowl/aka firewall near the fuse box.


Again, some of the ground numbering locations are going to change depending on year. Model year 2002 introduced significant wiring changes to the Super Duty over the 99-01 model years.


But the main point is this.... the PCM grounds in SEVERAL places, not just one place. And, the second point: the paths to these grounds can be routed through splices, and those splices can be buried in wiring harnesses that may still be neatly taped and wrapped, even after all these years. Do you really want to go digging through all those harnesses to mount a necklace of chokes?


If it works... obviously go for it. But choking and choking and choking a symptom may not be enough to solve a root problem. And it could very well be that doing something different altogether actually resolves the problem without chasing around the engine bay for every possible wire you can choke.


For example, we know that we have anemic alternators for the amount of battery capacity we must maintain, and the amount of electrical loads we draw, with 100 amp glow plugs, intake air heaters for those who still have them, 8 cylinders of 16:1 compression ratio that can require 400 amps of starting current, and thousands of amps of momentary inrush current, measured in microseconds of duration, but a big hit on those batteries all the same.


So our poor 110A alternator is huffing and puffing along, trying to keep those international airport landing lights that some of you guys are running lit, and by and by, one of the diodes in the alternator starts degrading. It may not fail suddenly. It may break down over time. Just one or two diodes, effecting one of the 3 phases of the alternator's AC current. Now, the failing diode causes the AC to start leaking, and where is the leakage going to go. If we can shunt the AC leakage directly to the DC battery, it would be absorbed, no harm no foul. But, if there is any resistance in the battery to block ground, from corrosion that capillaries it's way unseen into the cable, or from dirty connections, whatever the case may be... we can have EMI rippling around effecting hall effect sensors.


This happened to me. I speak from personal experience. It didn't effect my rock solid original black CPS sensor that is now 17 years old and still kicking, having never been changed. But it did effect a similar hall effect sensor that functions in the same way... the OSS on the back half of the transmission. One day out of the blue, the transmission won't go into gear right away. When I put the lever in Park, the rpms jump up to 1,500 and hold for long while before settling back down to idle. The TCIL starts flashing. I'm trying to get it to the safest place off the road as possible, and it starts shifting funny. I crawl it back home in 2nd on city streets, trying to recall what the final verdict was on all those BTS vs John Woods forum debates, wondering which kidney I need to sell, the left or the right.


And then it hit me... the alternator. I touched it, it was hot. Hotter than it had ever been before. No battery light. No alternator fault code. Nothing to indicate that the alternator was failing to work... but my premonition to check it's temperature lead to the diagnosis of bad diode. Bad diode means AC leakage. AC leakage means errant electro magnetic interference. Output speed shaft sensors and camshaft position sensors are magnetic sensors. The proof that the problem was the alternator was simple: I changed the alternator, and the transmission shifted normally again. No more transmission codes. No more flashing TCIL. This happened to me twice, because I have two alternators. So the first experience led me to solve the second experience quicker.


So, is installing a bunch of chokes just a bandaide that merely masks the symptom of a functional but partially failing diode in an alternator? Or is replacing the alternator also nothing more than yet another bandaid to mask the symptoms of an even more mysterious root cause? As much as I know with certainty, backed by multiple instances of personal experience, that bad alternators can be the root cause of a variety of seemingly unrelated problems... I also suspect that not even the alternator is the root cause of the problem, even when replacing the alternators FIXES how we experience the problem.


I suspect that we need to pay careful attention to the sequence of how the truck is grounded. For a variety of reasons beyond the scope of what is already too long of a post, I think that the only grounds that should be attached directly to the battery are the block to battery grounds, and any ancillary ground that Ford originally attached to the battery. Often times, the extra doo dads and aftermarket accessories that folks add are grounded directly to the battery, often by explicit instruction from the accessory manufacturer. I can clearly see their reasoning for this. But I can also see another path.


GM has a way of describing grounds as "Clean" and "Dirty". Clean grounds are segregated from dirty grounds, and what separates them is some degree of distance in the form of resistance. Dirty grounds are noisy, in that devices grounded at these points produce electrical noise. Clean grounds are for low current data devices, like ECMs and the like. I'm not convinced that Ford applied enough attention to detail on segregating clean and dirty grounds... even though Ford has grounded 9 separate circuits of the PCM in at least 3 different locations. But I'm also not convinced that I'm qualified to start relocating grounds to segregate noisy grounds like the freaking windshield wiper MOTOR from the same freakin SPLICE as one of the PCM grounds. Stunning design. Shakes head in disbelief.


The chokes are just a bandaid. The ground wiring schematic could very well be the root cause. I haven't added any chokes, but this is the bandaids that I did wrap around the engine bay:


Two heavy gauge ground wires bolted to directly to the cases of each of my alternators, and routed directly to the respective batteries they are nearest to. These additional heavy gauge ground wires... in my imagination at least... serve to shunt any AC leakage (from a future alternator diode degradation) along a path of least resistance directly to a welcoming battery ready to receive and absorb it... rather than have this leakage wandering all through the block and connected transmission, trying to find a job.to do, and effecting the hall effect sensors in the process. Even if my imagination is in error, these alternator to battery grounds still serve as redundant block to battery grounds, making up for any undiscovered or yet to materialize corrosion in the marginal OEM block to battery grounds.
 
401 - 410 of 410 Posts
Top