The Diesel Stop banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello all. So I'm having trouble with my fuel selector. So basically here's the story. I was heading out on a long trip and filled my front tank then went to the back which I believed was close to empty but it only took a few gallons. So I head out and around the time I usually switch tanksfrom frront to back I did so and traveled about another 30 minutes until my truck acted as if it had ran out of fuel. Second guessing my initial fuel up I figured I didn't actually fuel up the back all the way and only ran on the few gallons I put in. So I hitch hike a total of two time 5 gallons at a time with no luck getting it started or fuel delivery. Did the usual bleed lines but wasn't getting any out of the Schrader valve so first guess was lift pump. But as I've gotten trailered home and added another 5 gallons to the front I have noticed that the Guage has not moved from empty. Now my front usually read pretty accurate but the back only reads full when full and rapidly goes down to E but still has about 3/4 in it. Now I have read a lot of forums on this site and found a few wiring diagrams. I have disconnected the connector from the tank selector to find no power going to any terminal and only the ground shows as good. I have checked fuses and power coming from fuse box all being good. From what I can understand from the diagram there should be power at the connector to relay to the selector valve by the fuel tanks. I have a feeling it is stuck on the back tank which I suspect is empty. In the diagram there is a splice for the power just not sure where. Any help would be appreciated. Thank you
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
**** sorry it had power it was the motor on the selector valve. Replaced with aftermarket with a lot of modifications to fuel lines. Thanks for the response.
 
1 - 3 of 3 Posts
Top