The Diesel Stop banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi there everybody, first time posting but I have found some information useful on this site and so figured it would be a good place to start now that this thing finally has me stumped.

We bought a '88 Super Duty with the 7.3 IDI, I believe to be original, engine. This was back at the end of March. We are using the truck for landscape work and have had problems in the past, almost one after another, but it has done quite a bit of work with all the repairs we have been able to do ourselves. New mechanical lift pump, clear hose from that to the water separator, new injectors and return lines, new strainer in the tank.

About a month ago we had a problem, once or twice, with the truck revving on it's own. Did it in gear or idling in neutral, never really a lot of revving just slightly, maybe 500 rpm. We were also having power issues at the same time and blowing the return lines helped on multiple occasions, never really had any problem after that with it revving on its own until about a week ago.
A couple of the injectors were leaking and the truck would build an air bubble in the clear tube that seemed to be coming from inside the filter after sitting. Truck has almost always needed ether to start after sitting for more than a day since we bought it.
We just recently did the injectors and return lines hoping to prevent having to continue blowing the return lines out and it ran well for a couple of days before the surging came back with a vengeance.
There is still a small air bubble in the hose after sitting after the injectors were changed.

We did the oil change because it needed to be done anyway, no change to the surging. Sprayed the injection pump down with WD-40 because someone who has helped before suggested to and it seemed to fix it for a couple of miles but the problem came right back.

This has finally got us stumped, like I say, we have been able to fix everything before this but I cannot seem to figure out where to go next with this one. Sticking metering valve inside the injection pump?

We're also having problems with the 2006 F-350 6.0 Powerstroke that we just bought, 9 days after bringing it home from the dealership and it's been down since. We just registered a landscape business back in October of last year and so we really need to find a way to get one of these trucks running. I will post about the '06 in the other section of the forums here and add that link to this one.

Thanks in advance for all your time and advice.
Patrick
 

·
Registered
Joined
·
1,585 Posts
If the engine speeds up on its own up after it has been running, that usually means it is running out of fuel. Check fuel pressure at the Schrader valve, should be somewhere around 4 PSI. It is possible that the fuel metering valve in the injector pump is sticking. you can try soaking it with sea foam, by replacing the filter and priming it with sea foam, then let it run for a couple of minutes. Shut it down and let it sit over night. That might clear up the sticky valve...if it isn't completely worn out, that is. I've never heard of a governor "hunting" on one of these engines, but I wouldn't rule that out either. There isn't really any telling how old the injector pump is, is there? It might just be getting tired.
 
1 - 2 of 2 Posts
Top