The Diesel Stop banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I bought my son a IDI 7.3 with about 260,000 miles. Ran great for almost a year till last week. Wouldn't start, put a new fuel filter on and bled the air. Started and ran good for two days. Then wouldn't start, crank was slow. Replaced the starter and both batteries. Now good crank,still no start also no smoke. I'll add the tach hasn't worked for months but the truck ran fine without it, up till now...
 

·
Registered
Joined
·
1,651 Posts
Check the fuel shut off solenoid. Is the lift pump putting out?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Ran a jumper wire from the battery to the fuel shut off solenoid. Started right up, what could be keeping it from getting power?
 

·
Registered
Joined
·
1,651 Posts
I believe there's a fuse somewhere, I can't for the life of me remember where though.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
I've checked all fuses under the dash and in the fuse panel under the hood. I've got a new tach sensor ordered that'll be in tomorrow but what I'm understanding it don't power the fuel shut off.
 

·
Registered
Joined
·
1,651 Posts
It is in a common circuit with something else. If you can find the listing of what the fuse circuits are, you might find which one it is. You also might trace the wires out and see where it is broken. The tach sensor has nothing to do with the fuel shut off. The fuel shut off is controlled by the key switch through the fuse box to the solenoid. I don't recall if it goes through a relay or not, and don't have a diagram in front of me to tell you. When I don't know which fuse it is, I usually test them one at a time and find the guilty one that way. Then it gets marked as to what it protects
 
1 - 8 of 8 Posts
Top