The Diesel Stop banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Good afternoon all,

I bought a 1992 F-350, with a 7.3 diesel. Aside from the speedometer, I Drove it for a couple hundred miles and it was great. Noticed the od light was flashing, but nothing too crazy.fast forward to today and it seems to drop into limp mode, when driving. I’ve searched the old forums. I’ve replaced the VSS twice, just replaced the tachometer sensor. My FIPL is reading in the range I’ve seen on here ( can’t remember numbers off my head). It’s got 150k miles on it, fluids seem level, dash lights work, and none are constantly on. However it appears my vehicle doesn’t have a engine light on it. I also bought an innvoa scan tool, and don’t get any codes back ( when I hold acceleration down during steps). I’ll note that I didn’t replace theFIPL, but it’s getting the correct voltage. She rode for about 3 miles, until she started getting to temp, and starting crapping out.
Any advice would be greatly appreciated.
 

·
Registered
Joined
·
46 Posts
For years Bertha threw a code for transmission slippage. But these transmissions are famous for throwing that code when some of the electronics are the problem. So I changed everything! Finally after seeing the transmission temperature go up along with the rpms while losing power to the wheels I sprung for a new torque converter. Runs great....no more limping. Sometimes a duck is a duck. But you should get the code for torque converter slippage. (29?)
 
1 - 2 of 2 Posts
Top