The Diesel Stop banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello,

I'm having some issues with my veg conversion :

I'm using a two tank system, heated fuel pickup, in line prefilter, heated veg filter under the hood, and FPHE. I'm using a new stock mechanical lift pump for both fuels, which most people say works just fine. But - when i open the air bleed valve on my veg filter, a lot of air is apparent, and eventually after about 45 minutes of highway driving, the truck will stall due to all the air in the system. Runs fine on diesel. Any advice?

Today i tried connecting the lift pump directly to a bucket of clean veg, but the same amount of air is seen when we open the air bleed valve on the veg filter. Both filters are new and clean, veg is settled then filtered to 1 micron.
 

·
Registered
Joined
·
6,680 Posts
If you don't have problems on diesel, then the problem must be somewhere around your veg filter. Remove it and re-seal all the fittings. I like to use rectorseal #5, it's good for just about everything (water, gas, diesel, etc etc)
 

·
Registered
Joined
·
79 Posts
Re check all your hose clamps to be sure they arent allowing air to be pulled in ( that problem would happen before the lift pump.) . check all your hoses again on both sides of the solenoids to make sure they are hooked up to the correct ports and check for kinks in the fuel line. I had that happen once and it drove me crazy trying to figure out the problem. Do you have any other problems with the system? are you using a 6 port or 2 three port solenoids? check to see if you tank hasnt slide and piched a hose.
 
1 - 3 of 3 Posts
Top