The Diesel Stop banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I am trying to troubleshoot an issue I have recently discovered with a 1996 F250 7.3L SRW. The vehicle had been sitting for a couple months without being ran, and last week in preparation for me to come and pick it up ( I am Active Duty Army stationed in TX and truck is located in Oregon ) my father got the truck running and took it for a quick ride just to check everything out. He noticed that cruise control no longer works as it did previously as well as not wanting to shift into 4th / OD unless under heavy acceleration but will then come back out into 3rd with TC Lock up, so at 65 Mph its running about 2500 Rpm's. there is no CEL and the OD Light does not flash, he also stated that all brake lights work correctly and the fuses all looked good. I am headed out there this weekend to get the truck and drive back to Texas with it but want to rectify this issue(s) as I'm not sure where to look at this point and don't want to encounter issues during the trip. The Truck has 181k on the ODO and had a transmission rebuild roughly 3 years / 70k miles ago which it has had 0 issues since the rebuild until recently when it had sat and not ran for a couple months.
 

·
Premium Member
Joined
·
8,603 Posts
Make sure that that third brake light on the cab is working.

If it had the cruse recall done check the fuses just off of the master brake cylinder.

Is the speedometer working? It could also be the VSS on the top of the rear end housing.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Bugman,

he said the 3rd brake light was good, speedo and tach work fine, no bouncing or irregularities in performance. I'm not sure if the recall had been done, once I get there this weekend ill give those a look over, any way to test the VSS ?
 

·
Premium Member
Joined
·
8,603 Posts
If the speedometer and odometer is working then the VSS should be fine.

I am not a automatic fan so that is about all I know of that you can check if things are not working properly. On the cruse recall if you look at the master cylinder you can tell if it has been done or not. I'll add a picture of what it looks like, but I am not sure if you can see the fuses or not, but there is a big blue tag on the new part.
 

Attachments

·
Super Moderator
Joined
·
11,638 Posts
I can't think of anything in common that would prevent it from shifting into fourth AND keep the cruise from working. I can easily think of how no cruise and no torque converter lock could happen.

Are you certain that the converter is locking and that it isn't shifting to fourth gear with the converter unlocked? It's really easy to mix up the lockup and the 3-4 shift.

No lockup can be caused by a bad brake on/off switch on the brake pedal, a bad pressure switch on the master cylinder, or a bad brake light.
 

·
Registered
Joined
·
495 Posts
Just checking don't forget about the 3rd brake light that is where I had an issue once upon a time.
 

·
Registered
Joined
·
14 Posts
I just dealt with the same issue mine was a combo bad third brake light and a 7 pin trailer connector in the bed had rubbed through and shorted. Mine was shifting into 4th but torque converter not locking. Bet possible a mouse got ur wiring while it was sitting. Let us know what u find.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
I was able to resolve the issue, turns out something ate a wire in the wiring harness in the engine bay. spliced and soldered a new wire in and everything works as it should... minus the speedometer needle bouncing at speeds over 60 mph. I replaced the speed sensor in the rear differential with a motorcraft replacement, also had to replace the connecter as the retaining clips broke but that did not resolve the bounce. tachometer doesn't bounce and there are no SES light or ABS light.
 
1 - 8 of 8 Posts
Top