The Diesel Stop banner

1 - 4 of 4 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
First of all.. my truck runs really rough when cold and has no power.
already changed injector o-rings, icp, and rebuild ipr. Got new oil, and all filter.
New GPR as well

Now:
i had my PCM re-flashed yesterday at the Ford Dealer, so the A & E Software works.(my truck is a late 95).
Ford Dealer said, my idm throws an error and is bad..

Today we connected with the A&E Software.

Did Buzz-test and first test, 4 cylinders did not buzz and had an idm error. did a second test, just to make sure and only #3 did not buzz.

We changed the IDM with a newer one from a 97 4x4 F250, just to test.
Now #3 did not fire right.
cranked the truck (ran better) went on test drive.

HPOP at idle is at 567
at wot it holds steady between 2500 and 2470.

exhaust back pressure is 17 at idle, tops out at 35 at wot
manifold pressure is 16 at idle and 30 at wot.

The CCT test came back with P0266 (cylinder fault #2) and P0272 (cylinder fault #4)

did a Buzz test, once we stopped and all cylinders were fine.
Installed my old IDM, all injectors buzzed, but still get IDM failure.


Please advise on all data and what to replace .
btw.. i was thinking of replacing the uvch.
 

·
Registered
Joined
·
352 Posts
Check all the wiring & connections on top of the engine (as well as UVC harness). Such inconsistent test results and symptoms with a known good IDM would lead me to look for wiring/connection issues. I once repaired a harness that had been previously but inadequately repaired. While diagnosing the problem, I could rev and/or kill the engine by moving the wire harness. The repair required removal of the entire top of the engine harness for some serious rebuild. The initial reason I was even looking at the van was the owner stated it was a bit sluggish. I looked into it after he had changed the oil along with all the filters (air, fuel, oil).

I hope this helps.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
when i did the injector o-rings i inspected the harnesses and they looked good.
only thing i noticed was that on 3 out of 4 plugs , the locking clip was broke. The connectors are all the way in and have not come loose. But for this reason, i plan on replacing the uvch inclusive the wire pick-tails.

would a pad harness give me an a&e code for a bad idm ? the same thing ford dealer said ? because i did not get that code with the borrowed idm. also after the truck was warm, #3 buzzed ok...

if i buy an IDM, where should i get one ? any dealer wants to make me an offer ?
 

·
Registered
Joined
·
24 Posts
Discussion Starter #4
i plan on purchasing some parts today, so i can do the work over next week long weekend. Also plan on replacing my downpipe.

If anybody has advice on my questions , please let me know
 
1 - 4 of 4 Posts
Top