The Diesel Stop banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
this is from a 1997 f450 7.3l turbo diesel.... I am holding my foot steady at 60 MPH but my rpms are changing for some reason. And when it goes up, truck doesnt feel weaker, just kinda sounds like its pulling a trailer and when it idles back down, its just a normal good ride. I have changed fuel pump, fuel filter, oil, oil filter and added lucas diesel conditioning to see if it would remedy this problem. Fuel pump was leaking, thats why i replaced it. I cant understand the rpm and motor changing. I am not doing this with my foot. I thought it was changing gears out of overdrive, so i push the over drive off and it goes up over 3k rpm at 60mph, so its not switching back and forth from overdrive and 3rd.

go here to listen and see what im talking about....

and since we are on the subject of my truck... my oil pressure gauge reads all the way low when i push on the gas and reads about midway during parked idle. And yes, i have the right amount of oil in the truck. im guess its just the oil sending unit.

and, all i ask is to respond in regards to my truck problem, not my forum grammer or english 101, hate when people do that!! thank you:read:
 

·
Registered
Joined
·
95 Posts
Looks to me like the torque converter is slipping or unlocking, how does your transmission fluid look? I know the E4OD tends to have torque converter problems once you cook the fluid. Does it ever bounce or shudder driving around like you're driving on odd shaped tires?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3 (Edited)
well. it was low on trans fluid. Would stall out and die if i stopped quickly or sometimes when i put it into reverse. I assume the oil was burned off or cooked cause i have had no trans leak. I put fluid in with also Lucas conditioner. Doesnt stall out when put into reverse anymore or when braking. I do however, have developed this rpm thing on the highway
205k miles
I can also hear i little whining nose when accelerating or gear changing... like a power steering pump but it sounds from the engine. The steering pump doesnt whine when turning wheels. i hear it when accelerating and idling down. this is an automatic transmission i guess i should add.

Havent noticed any shudder wheel driving besides when tires were bad.
 

·
Registered
Joined
·
95 Posts
I have the exact same transmission. The E4OD HATES heat so if you were able to burn the fluid off you've had some serious heat inside that unit and more than likely done some pretty extensive damage. I'm pretty sure what you have going on looks like a failing torque converter locking and unlocking at will. Can you try running the truck in 3rd gear lock up with the OD off to see if it does it there as well?
 

·
Registered
Joined
·
32 Posts
Ill second the torque converter locking and unlocking. However I had the same issue when one of my rear running lights went out, also check the 3rd brake light.

Long shot but you might get lucky.
 

·
Registered
Joined
·
95 Posts
Ill second the torque converter locking and unlocking. However I had the same issue when one of my rear running lights went out, also check the 3rd brake light.

Long shot but you might get lucky.
Very true! It could be corresponding with a short in wiring for the braking system unlocking and locking the torque converter. It's a long shot though.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
thanks guys. i took it to a transmission shop and he said it seems to slip on each gear clutch and the torque converter is in rough shape all by him simply driving it. I do have a third brake light thats been out though, lol. would like that scenario much more.
 

·
Registered
Joined
·
95 Posts
Seeing as it isn't too much cost it might be worth it to throw a bulb in that brake light. Yes the damage to the trans is done and that mileage is up there for a, excuse my use of the word, "abused" E4OD :lol: However, it may push the problem off a bit. Also it's usually a good idea to get a second opinion on something like a transmission if you haven't used the shop before. Good luck :thumbsup:
 

·
Registered
Joined
·
4 Posts
Discussion Starter #9
JEFF AND CARSON>>> THANK YOU!!!!!!! THANK YOU !!!!!! THANK YOU!!!!. i wiggled on brake wires and the problem stopped. My trans and truck is running great. No missing or anything. Im lucky since i was low on trans oil that it is driving so smooth. I know its the wires somewhere because now that it isnt doing it all the time, it will when i turn my left turning signal on. So i assume i may have a brake/ turning wire touching or something on the left side. I have an utility bed on this truck and my tools in the boxes could have rubbed the wires or something. I will take a closer look to find the short in the wiring but THANK YOU GUYS SO MUCH. NO one i talked to around here ever heard of such a thing. I cannot be more thankful, i give you all a pack of beer or something if you was near!
 

·
Registered
Joined
·
95 Posts
that's why the forum is here! glad i could help!! :thumbsup:
 
1 - 10 of 10 Posts
Top