The Diesel Stop banner

1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi my ABS has been on ever since i purchased the truck used. The code was to replace the ABS module so i replaced it and the light is still on. The truck will suddenly die and easily start right back up. the Speedo goes to 0 and bounces around. Whenever the ABS light is on the truck will die. I replaced the ABS module, the VSS and the two front ABS wheel sensors. If anyone could help try to figure this problem out that would be great, I've been throwing money into this thing and trying to figure it out for a while now and any help would be much appreciated.
 

·
Premium Member
Joined
·
678 Posts
You need to put information in your signature and let everyone know what year, model, etc. your truck is to get any educated opinions.
What code did you pull up? Also, maybe not related.....but a bad front wheel bearing hub will cause the abs tone ring / sensor to make the ABS light come on.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
My bad, its a 2006 F250. When I replaced the ABS wheel sensors I noticed that there was a some grease on the pickups, i wasnt sure if it would cause a problem so I overlooked it, not sure if that could cause a problem??
 

·
Premium Member
Joined
·
678 Posts
2WD or 4WD
 

·
Premium Member
Joined
·
678 Posts
As for the grease, you’ll have to get the opinion from others here.......I’ve heard of some guys adding grease through the ABS hole — whether it can get down into the bearings where it needs to be I don’t know.
 

·
Premium Member
Joined
·
678 Posts
How long have you had the truck? My ABS light came on when I was having trouble with a right front, bad bearing hub. Replaced hubs and ABS light reset itself, but the light being on didn’t have any effect on engine performance. Any other codes? CPS? Not a bad idea to carry a spare— Motorcraft.....don’t buy an aftermarket.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
I’ve had the truck for almost a year and I don’t see the bearing hub having a problem with it stalling either but I can tell the abs and the stalling are related. It’s a 4wd
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8 (Edited)
I changed the ABS wheel speed sensors on the front wheels and the problem went away for a bit but the light stayed on. I was driving it yesterday and it started cutting out again. any suggestions would be accepted.
 
1 - 8 of 8 Posts
Top