The Diesel Stop banner

1 - 3 of 3 Posts

·
Registered
Joined
·
335 Posts
Discussion Starter #1
1993 F-350 CC Dually 164,xxx miles 7.3 idit
Started getting noticeable air intrusion a couple month ago.
Return line caps, o-rings and connecting hoses were replaced about 8000 miles ago, however 8000 miles ago was January 2013...
After some research I installed clear vinyl hoses from the IP to drivers side return, fuel filter to passenger side return and return to fuel tank at the back of the engine.

Start the truck and once the air purges I don't have any bubbles from the IP to return but I have a lot of bubbles from the passenger side return to the filter and a few bubbles out the return to tank. If I crimp the line between the fuel filter and passenger side return and get a lot of bubbles out the return to fuel tank line. IP to drivers side return remains bubble free. No visible fuel leaks anywhere.

Shut off the engine and I get air in all three return lines.
I attempted to install a clear line on the suction side of the lift pump but my clear hose was to soft and just collapsed. I did discover the rubber hose down there was in very poor condition so I replaced with new.

From the youtube video where I learned about connecting the clear lines, the author suggested that air between the passenger return and the filter indicated bad return line caps or o-rings. The current return system only has 8000 miles on it but are over 6 years old. Typical of internet forums, some research indicates the return line system should be replaced every couple of years and other folks say a newly replaced return line system should be good for 100k miles.



Before I start throwing parts at it I'd appreciate advice from the 7.3 gurus.

Thanks!
 

·
Registered
Joined
·
1,664 Posts
I would check the return lines on the right side. Remember, air will get in where fuel can't get out. Pour a little fuel around the caps, and hose ends and see if the bubbles go away for a short time. Might help you identify the culprit. You should also check the line from the filter to the IP, the rubber ferrules can get hard and crack, while you're at it, check the line between the filter and the lift pump, same reason.
 
1 - 3 of 3 Posts
Top