The Diesel Stop banner

21 - 32 of 32 Posts

·
Premium Member
Joined
·
470 Posts
Make sure you are on “Full Version” and not Mobile, then look at klhansen’s profile. You will see it listed- click on it and it will take you to the sticky note he has set up.
 

·
Super Moderator
Joined
·
25,020 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #23
Update. I changed all 8 glow plugs. Tried to start it this morning, no luck. Had both batteries load tested and the guy at autozone said the were both at 100%. So far I've replaced the GPR, CPS, glow plugs, and changed the oil using 15-40 Rotella with Hotshot stiction eliminater. Has a new ICP from the previous owner. I've also cleaned the battery connections. Truck has some blowby but won't blow the cap off. If it is plugged in for a couple hours it fires right up at 45 degrees. Still racking my brain. Any help is appreciated.
 

·
Premium Member
Joined
·
3,882 Posts
Did you test the new GPR using the “No Start” instructions just to confirm its working?

So its still exactly like before? It starts quickly when the block heater is plugged in but does not start when not plugged in?

And you have inspected the ICP? Unless you replaced it yourself with a Motorcraft ICP then you can’t really be sure. New ICPs can fail. But the fact it runs good as soon as it turns over indicates the ICP has not failed completely.

You mentioned you had it scanned but did not mention the type of scanner. Most parts store code readers do not read Ford specific codes as was mentioned earlier.

You really need to download an App or buy a ScanGuage-2 and read some engine values or its just more throwing money after it and hoping to get lucky.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #27
I tested the GPR and verified that it is working. I tested all 8 glow plugs and I am getting around 1.6-1.5 ohms. I have an app but the bluetooth obd2 scanner that i have isn't compatible with that specific app. I am currently waiting on one from Amazon but as you know I'm in Fairbanks and it takes alittle time for things to ship up here.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #28
Update. So I got an Edge Insight cts2 and have been monitoring it for about 2 days now. What should I be looking for in terms of monitoring? My ipr duty cycle is about 6% at idle. Icp sits at about 480 psi at idle. I've done alittle reading on other threads and those values seem low. Thank you for any input
 

·
Super Moderator
Joined
·
25,020 Posts
IPR of 6% at idle is a bit low, but 480 psi ICP is good. That in itself would indicate a possibly partially obstructed edge filter.


But your ICP at max power of 2400-2600 psi is fine as well and IPR duty cycle of 60-65% is within limits for a stock tune.


Is it running OK?
 

·
Registered
Joined
·
20 Posts
Discussion Starter #31
It seems to have a bit of a lope to it especially the colder it is. At operating temp it still has a lope but alot less prominent.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #32
Seems as though I found my solution. Bad compression... No I'm just kidding it was injectors lol. Swapped out my old ones for remans yesterday. I let it sit over night in at about 40 degrees and she fired right up instantly. Better throttle response and definitely more power on the low end. Thanks for the help guys! Safe to say I'll be drinking to that 🙂
 
21 - 32 of 32 Posts
Top