The Diesel Stop banner
21 - 26 of 26 Posts

· Registered
'02 7.3L Excursion 3.73 Warn Hubs AutoTranny
Joined
·
161 Posts
John, after starting what is your voltage while the glow plugs are still on?
I have a Digital VM plugged into the Cigarette Lighter power socket, I don't recall actually taking a real close look at it, I will try and make a video recording though, snowing now.

but IIRC, some what close, it is still close to 12 volts or in the middle 11s
Don't hold me to that, but I will get a video as soon as I can.

I keep a Battery Tender on the truck, so it is always Floating at 13.3 to 13.6 before the Key is turn ON. had to change the batteries out a couple weeks ago, they were ruined when I bought the truck last June 2022... and I just suffered through until I finally got the Parasitic Draw Fixed..... then I bought new batteries...

I keep Battery Tenders on everything we own here,
EZ Go golf cart, old from the early '90s ( just put $1500 worth of new batteries in it​
...... 1st time the Trojan I replaced batteries, and I bought it used in 2005 )​
RV trailer​
Zero Turn mower​
'01 Suburban​
'02 Excursion​
'58 Kubota tractor​
'09 Piaggio MP3 scooter​

the old EZ Go batteries, I keep a very expensive trickle charger on them. I monitor water level close every 60 days, Distilled only.


Cuisine Luggage and bags Cake Rectangle Bag



Summit brand Charger --- gets plugged every time Cart is left unused, period......


Automotive tire Motor vehicle Water Bumper Gas
 

· Premium Member
Joined
·
1,286 Posts
Thanks John, so...... the reason I ask, I had thought about a H/O alternator since I have the 17,500# winch attachment for my truck. (But haven’t ran into an issue with my two stock batteries so far using my high idle tune). But I don’t want to run over 11 volts while the glow plugs are on. There’s no hurry, when you get time and are out and about..... I hope we don’t get hit with much snow🙄but just in case I hooked up the plow after work last night

Tire Wheel Automotive parking light Car Land vehicle
 

· Registered
'02 7.3L Excursion 3.73 Warn Hubs AutoTranny
Joined
·
161 Posts
Not familiar with H/O brand...
oops, you mean a High Output.

I can Testify to 10 Star Customer Service with MechMan brand.

I bought their 320A version, they have one in the 500 Amp range also.

It works flawlessly, at Idle the Alternator holds 14.6ish with both front and rear A/C fans on High and Max Cold in my Excursion....


I was trapped in Podunk, Utah ( Price ) last summer with Codes throwing left and right....
was referred to a great diesel repair shop ( Kenworth, Mack, PeterBilt, etc... ) and they took in my '02 Excursion to try and work on it..... they traced the problems down to a bad Alternator...

they were unable to find one anywhere close to them, asked me to find one, and they would install it...... I decided to suffer the Wallet Strike, and went for the MechMan after searching the 'net and reading reviews on all brands. I called them on phone, paid for it, they shipped it direct to the diesel shop.... made me happy, my sister's ranch is 20 miles away in the desert and deliveries there are spotty.... it was at their shop 2 days after I hung up the phone, Free Delivery..... FedEx carried it to them.

I have gotten over the Debit charge now, and just grin every time I see that Digital VM in the Power Port staying at 14.4 to 14.8 all the time; Idle or cruising.

MechMan Alternators


My install;

Motor vehicle Vehicle Automotive tire Hood Wheel




Automotive tire Motor vehicle Automotive lighting Automotive design Vehicle



that little blue DVM is always 0.3 volts higher than my Good DVM sitting on the Battery Terminals.... don't matter, it shows the current STATUS of the electrical system.

let me know which one you choose for that Snow Plow.... guarantee this brand will do the job.
 
  • Like
Reactions: Greg687

· Premium Member
Joined
·
1,286 Posts
I’m OK with that kind of voltage after the truck has been running but do not want that while the glow plugs are ON. They were not designed for that.....if I remember they were designed for 10....maybe 11 volts. There’s been a lot written on protecting the glow plugs (99-03) from too high of a voltage.

Glad you’ve had good luck with the MechMan. My voltages stay in the upper 13’s with my stock alternator but I don’t have the winch on for long periods and the small snowplow winch doesn’t pull much of a load.
 

· Premium Member
Joined
·
1,286 Posts
Here’s some of a conversation taken off another site:

Operating at excessive voltage, where instead of a 110a alternator being too anemic in power output for system voltage to immediately rise after start, I have a 230a alternator that very quickly rises to the voltage regulator max of 14.1 volts within seconds after starting. The previous 110a alternator took a couple of minutes to rise to 14.1 volts. During that couple minutes that it took for the 110a to catch up to demand, the glow plugs were safe. And according to Ford's memos, this was by design. Once I deviated from that design with a higher amp alternator, I ran the risk of applying "excessive voltage" to the glow plugs while they were being heated from within, and without, due to combustion.

2. Ford commanding that the GV series 2 stage glow plugs stay on after engine start is the same as the "relay sticking", or staying on too long for the GV series 2 stage design.

3. "Incorrect post heating with engine running"... Yep, that is exactly what is happening. And we can't change to the 6.0L GN 3 stage glow plugs that were designed for this type of post heating while engine is running... because the ZD-13 glow plugs do not fit the 7.3. And Beru does not make a GN series 3 stage glow plug that matches the GV819 dimensions.

4. "Post heating glow plugs not used." GV series are not post heating glow plugs. And we can't change to the 6.0L GN series 3 stage glow plugs that were designed for this type of post heating while engine is running... because the ZD-13 glow plugs do not fit the 7.3. And Beru does not make a GN series 3 stage glow plug that matches the GV819 / ZD-11 dimensions.






So here is the wrinkling and dented heating element of Cylinder 3, which also had a "filament open circuit"... showing an open on the DVOM.

This is what I caution anyone considering upgrading their alternator to consider. Do stock glow plugs fail frequently, or are there not so obvious conditions created by a charging system "upgrade" that are actually accelerating glow plug failure?
 

· Registered
'02 7.3L Excursion 3.73 Warn Hubs AutoTranny
Joined
·
161 Posts
I am definitely going to install a LED light connected to the Glow Plug Relay on my truck.

it now has a 320A alternator....
Prior to yesterday, it was wired up wrong, and was putting out full Force Darth Vader at 14.5 plus the instant the engine started....

guess I been lucky so far?
The glow plugs still "seem to be" working, in that the truck starts right up, after I count to 20 AFTER the WTS light goes off.
 
21 - 26 of 26 Posts
Top