The Diesel Stop banner

1 - 5 of 5 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1 (Edited)
I just completed the installation of my 6 Gun Tuner, Speed Brake and IQ module .. I am getting an Error 34 CAN indicating that I have an ECM or ICM error on the truck .. Since this is the first time I am trying to start the truck since I connected the Banks equipment and the fact that just yesterday the truck ran fine without the Banks equipment .. I can only assume that something is either wrong with the unit or the connections.. Speed Brake 1 solid green ,, Bridge 2 blinking green .. Banks IQ v1.4 ,, Bridge v2.0 .. Tuner 63746 .. Tuner firm v6.0 .. Cal v 1 ... I have owned this unit since October 2010 ,,, just got to install .. any suggestions // Big Hoss Bundle ... Exhaust, Intercooler, RAM Air intake, Tubes, 6 Gun Tuner, Speed Brake and IQ PDA
 

·
Registered
Joined
·
1,339 Posts
I just checked the Banks manual and here is the recommendation from them.
Turn ignition OFF and check the 4-pin male and female turbo
actuator connectors. Turn ignition back ON and re-check for
presence of code. If code does not re-appear at key ON, start
engine and check for presence of code both at engine idle and
under varying driving conditions.
Try it and see if it helps.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
Thank you for the feedback .. unfortunately this is a 6.0L 2006 which does not have the Turbo connectors .. There is only PCM, MAP, Brake Pedal Sensor, Brake Pressure Sensor and Tow/Haul interrupt connectors ... in addition there is a +12v power tap
 

·
Registered
Joined
·
1,339 Posts
I think I would check to make sure none of the pins are bent on the PCM. It is a fairly tight fit and it is easy to bend one when plugging in to the PCM. ALso, does the Banks unit plug in to both the engine and trans connection at the PCM? if so make sure they are not reversed. The trans connection is the middle and the engine is the back connection. The other question is, has the truck been flashed since you bought the Banks? If so you may need to update the Banks unit.
 

·
Registered
Joined
·
14 Posts
I talked to banks just last week about my v2.0 IQ. It was acting crazy. If you downloaded the software (Banks downloader on your desktop) over 8 months ago, they are saying to uninstall it. Go to the website, download it and then reupdate the IQ, bridge, and tuner software. The old downloader was causing the downloads to be corrupted and links and other software to go bad. Check your hardware, do the software fixes, thend if it is still a problem, call banks, even if you didn't buy it from them directly, they will still try to help resolve the issue. I have never had a problems with them.
 
1 - 5 of 5 Posts
Top