The Diesel Stop banner

21 - 40 of 79 Posts

·
Registered
Joined
·
70 Posts
I'll do the same, thanks Bankspower.

Dan
 

·
Registered
Joined
·
80 Posts
Will send PM first thing tomorrow morning. Thanks!
 

·
Registered
Joined
·
70 Posts
Bankspower, PM sent and thank you.

Dan
 

·
Registered
Joined
·
1 Posts
Banks Warranty

My IQ had same issues as all comments. Additionally, first thing in the morning, going around a sharp, higher speed turn (cloverleaf onramps), the BanksBrake alarm would sound and show a trouble warning. After straightning out, the alarm would go off and all would be well. With slightly less than a year on the IQ, Banks repaced the Bridge and harness under warrantee. 6 months later, noting the same problems, culmanating with a complete failure of the IQ - it would come on and I could use the accessory stuff but not the IQ stuff, I took the truck to Banks and they warranteed the IQ. I'm fortunate that I live close enough to Banks, and I had them do the original install. I also had multiple problems with my original Power Pac until I started taking it off the dash to keep it out of the sun.

I love my system, but reliability rivals that of my 6.0
 

·
Registered
Joined
·
464 Posts
My IQ had same issues as all comments. Additionally, first thing in the morning, going around a sharp, higher speed turn (cloverleaf onramps), the BanksBrake alarm would sound and show a trouble warning. After straightning out, the alarm would go off and all would be well. With slightly less than a year on the IQ, Banks repaced the Bridge and harness under warrantee. 6 months later, noting the same problems, culmanating with a complete failure of the IQ - it would come on and I could use the accessory stuff but not the IQ stuff, I took the truck to Banks and they warranteed the IQ. I'm fortunate that I live close enough to Banks, and I had them do the original install. I also had multiple problems with my original Power Pac until I started taking it off the dash to keep it out of the sun.

I love my system, but reliability rivals that of my 6.0
PM me the info above and we'll get this fixed for you:D

Bankspower, PM sent and thank you.

Dan
Will send PM first thing tomorrow morning. Thanks!
Thanks guys we're working on it now. If anybody else is having the same issue make sure to PM me the requested info and the EXACT issue you're having and we'll get it sorted out:D
 

·
Registered
Joined
·
80 Posts
Sent PM this morning.
 

·
Registered
Joined
·
4,742 Posts
Thanks for the update. I am sure the Tech's will figure it all out.
 

·
Registered
Joined
·
464 Posts
Sent PM this morning.
Thanks for the update. I am sure the Tech's will figure it all out.
Thanks guys. Engineering is working on it now. It may be due to a voltage issue the 6.4L's tend to have. When the truck sits for a while the voltage drops slightly and during startup it drops a lot. The voltage spike may cause the comm error but we should be able to program around the issue (providing that's what it is). I'll keep you posted and be sure to use the link above to keep your system up to date:D
 

·
Registered
Joined
·
80 Posts
Thanks for going the extra mile to hopefully correct our issues! This is why we buy your products. :thumbsup:
 

·
Premium Member
Joined
·
244 Posts
PM me the info above and we'll get this fixed for you:D

Thanks guys we're working on it now. If anybody else is having the same issue make sure to PM me the requested info and the EXACT issue you're having and we'll get it sorted out:D
Hi Jeff,

I just read the last several posts tonight - I haven't been driving the truck either. I'll try to get the data you need and PM it tomorrow... good job, as usual!
 

·
Registered
Joined
·
3,532 Posts
not good advertising for those of us who haven't bought yet
 

·
Registered
Joined
·
80 Posts
not good advertising for those of us who haven't bought yet
Your looking at it from the wrong angle. Everything has their issues, and any company can sell you a product... it's after the sale when the company shows their true colors. These problems we are having are failry minor if you have read them and if you think there is a product out there your going to buy which will be 100% perfect all the time...your wrong. Banks has gone out of their way to come on here and acknowledge that they are willing to help and get the ball rolling faster than if we were to just call in to the tech line to get a fix. How many other manufacturers do you see on here actively helping out customners?
 

·
Registered
Joined
·
4,742 Posts
I think this is when the warranty of Banks shines. Never do they bat an eye if there is a failure.

true it is something we should not see.
 

·
Registered
Joined
·
464 Posts
For all those having issues, how long does you truck sit between uses? Overnight, a few days, a week or more? We have 2 trucks here right now that we're going to be testing on in the next 2 weeks. What we're doing now is trying to replicate the problem so we can record exactly what happens when the communication is lost:D
 

·
Registered
Joined
·
70 Posts
For all those having issues, how long does you truck sit between uses? Overnight, a few days, a week or more? We have 2 trucks here right now that we're going to be testing on in the next 2 weeks. What we're doing now is trying to replicate the problem so we can record exactly what happens when the communication is lost:D
Mine will sometimes sit for 1-2 weeks, however my issue does not show up until 75-100 miles into a trip.
 

·
Registered
Joined
·
4,742 Posts
1-2 days and it will show up.
 

·
Registered
Joined
·
70 Posts
For all those having issues, how long does you truck sit between uses? Overnight, a few days, a week or more? We have 2 trucks here right now that we're going to be testing on in the next 2 weeks. What we're doing now is trying to replicate the problem so we can record exactly what happens when the communication is lost:D
Can you also see why they might think my mpg's went up so much and then just disappears back to the 9's.

Dan
 

·
Registered
Joined
·
16 Posts
Discussion Starter #38
Mine only sits overnight and I get the problem. Lately its also been losing communication while driving and I'll have to reset it.
 

·
Registered
Joined
·
80 Posts
Just when it sits over night (8-10 hours). Here is the funny thing, this morning it was perfect. I had zero issues when I went to start it and I dont know why? The only two things that were different about last night were 1) I serviced my truck at approx 4pm yesterday afternoon. 2) The temp only went down to about 49* last night. All the others night the temp goes down to about 40*. Figured I would let it be known about the differences yesterday when I shut the truck off when I got home, as compared to all the other days.
 

·
Premium Member
Joined
·
244 Posts
Mine only sits overnight and I get the problem. Lately its also been losing communication while driving and I'll have to reset it.
That's my problem too... I have only had the "Startup problem" once or twice. It loses "Comm" while driving, sometimes 2 or 3 times in a 3 or 4 hour trip.
 
21 - 40 of 79 Posts
Top