The Diesel Stop banner
1 - 5 of 5 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
had a stiff pedal issue start happening found a broken hose on my vacuum pump changed it out but seen that my hydro boost is leaking inside the cab time for a new one ? Not sure if my vacuum pump was the issue for the stiff pedal randomly got it home no issues but wondering if the leaking hydro boost is causing that as well ? Also side note this just recently started happening could it be something to do with my viper alarm system that I paid to have installed ?
 

·
Registered
Joined
·
499 Posts
The vacuum pump doesn't do anything for the braking, however any leaking from a hydraulic system is bad. So, yes, I'd be replacing the hydroboost, and no, I can't think of anything an alarm installer would do that could mess one up, other than stepping on the brake to stop the truck while pulling it into a bay.
 
  • Like
Reactions: DENNY

·
Registered
Joined
·
4,988 Posts
I agree with Greg. Check you Power Steering fluid level. Looks like the Hydroboost is bad so replace that also.
DENNY
 

·
Registered
Joined
·
1,931 Posts
Not to highjack the thread, my brakes failed last week and the pedal went down almost all the way to stop it.
I also lost the A/C, the Vac pump is not opening the vents. So I will change the Vac Pump and check the PS fluid. I don't see any fluid leaking, I need to pull the carpet up behind the brake to check for leaks. The other thing was the left brakes were smoking and it felt like the caliper was stuck, pulling tom the left. I want to make it drivable so I can go to a shop and have them check the rotor and caliper. I have a Mag Hytec pan on the 4r100, anyone know the fluid amount, mine is the 2000 with the drain plug in the torque converter.

best to the Mods and Members here.
 

·
Registered
Joined
·
499 Posts
Not to highjack the thread, my brakes failed last week and the pedal went down almost all the way to stop it.
I also lost the A/C, the Vac pump is not opening the vents. So I will change the Vac Pump and check the PS fluid. I don't see any fluid leaking, I need to pull the carpet up behind the brake to check for leaks. The other thing was the left brakes were smoking and it felt like the caliper was stuck, pulling tom the left. I want to make it drivable so I can go to a shop and have them check the rotor and caliper. I have a Mag Hytec pan on the 4r100, anyone know the fluid amount, mine is the 2000 with the drain plug in the torque converter.

best to the Mods and Members here.
sounds like your brakes failed form heat. Usually it's the proportioning valve that caused one side to stick like that, so that needs to be looked at, the left side calipers, rotors, and pads need replaced, and the fluid flushed, at a minimum.
 
1 - 5 of 5 Posts
Top