The Diesel Stop banner

1 - 17 of 17 Posts

·
Registered
Joined
·
127 Posts
Discussion Starter #1
I was driving home this evening and my check eng light came on the started running rough and not enough power to hardly move the truck. Was sitting at stop light and check eng light went off and started running fine. It keeps coming on and going off with the same simptoms each time. I hooked scanner up and cant get any codes out of it to give me even a place to start thanks matt /ubbthreads/images/graemlins/shrug.gif
 

·
Registered
Joined
·
4,864 Posts
If your check engine light came on there ARE codes on the PCM...what kind of scanner are you using? Does it have a chip?

-Casey
 

·
Registered
Joined
·
213 Posts
My guess would be the wire harness under the valve cover.I had the same symtoms and these guys diagnosed it and even told me how to figure out which side it was on.Get it scanned first if you can though just in case.Good luck,Calvin
 

·
Registered
Joined
·
4,864 Posts
hmmm, thats odd that you arent getting any codes...I would pull the oil cap off and smell for burnt electrical...and you can inspect the 4 VC harnesses (2 per side) for burnt/melted plastic

-Casey
 

·
Registered
Joined
·
957 Posts
[ QUOTE ]
using snap-on scanner that i have used in the past to get my codes but none there this time matt

[/ QUOTE ]

Which Snap-On scanner?
 

·
Registered
Joined
·
3,330 Posts
Naw, but make sure there is nothing burnt in any of the plugs AT ALL, even the slightest could cause the injector wire to be burnt and to run crappy, check again but if those arent burnt I wouldnt worry bout pulling the covers, correct me if I am wrong guys
 

·
Registered
Joined
·
957 Posts
[ QUOTE ]
Naw, but make sure there is nothing burnt in any of the plugs AT ALL, even the slightest could cause the injector wire to be burnt and to run crappy, check again but if those arent burnt I wouldnt worry bout pulling the covers, correct me if I am wrong guys

[/ QUOTE ]

I agree with 94. If theres no burn leave the covers on. I would use a different scanner. I'm not sure why a Snap-On wouldn't read the code. Anyway go back to square 1. If theres a Check Engine Light or CEL there is a diognostic code in the PCM.
 

·
Registered
Joined
·
8,669 Posts
exact symtoms of a burnt harness , most of then burn inside not out, I can not think of anythign else that makes teh truck act like that, buy yourself a harness tehn pull a cover and look.
 

·
Registered
Joined
·
22 Posts
I had the exact same thing happen to my 97. Engine went
flat, with CEL on. Ran on snap on scanner but no codes
other than I think P1111 system pass. Happened several more
times, and I noticed that if I kept my foot on the throttle
that the CEL would stay on. As soon as I let off, CEL went
out and it came back to life. Was thinking it might be either
the idle validation switch or TPS. Might look in this area?
My problem went away on its own so I'm not 100% sure that
was it.
good luck, and let us know what you find.
Brent.
 

·
Registered
Joined
·
8,669 Posts
what would a throttle problem have to do with rough running? neither situation is remotely related.
 

·
Registered
Joined
·
127 Posts
Discussion Starter #14
Used another friends scanner and got codes p0264 Cyl 2 injector ckt low and p0344 cam pos sensor ckt intermitent. got the cam sensor one first changed it out and drove it 30 miles and it did it again and checked codes and got the cyl 2 injector ckt low so pulled the drivers valve cover and bam what do ya know the wireing harness and the gasket are both burnt. Question is would the wiring burnt make it throw the cps code? i have had intermitent problems with it just dieing going down the rod so think both finally just gave out thanks matt
 

·
Registered
Joined
·
4,864 Posts
most likely a glow plug problem...when you have the VCs off, ohm the glowplugs...a good glow plug should read .1 - 6 ohms...if it is >6 ohms or read OL its bad...

What I would do, if you have the VCs off ANYWAYS, just replace them...

-Casey
 

·
Registered
Joined
·
8,669 Posts
change teh GP that is on the burnt harness or it will jsut do it again, teh GP gets old and needs more juice to work, like the rest of us old guys, then it overheats the wiring causign it to burn out then as it continues it melts teh injector wire too teh " low side" hence your code.
The CPS is teh stalling and you were correct to change it out as well.
 
1 - 17 of 17 Posts
Top