The Diesel Stop banner

1 - 16 of 16 Posts

·
Registered
Joined
·
108 Posts
Discussion Starter #1
When driving home friday had to pass 3 cars they thought it was cool to do 40 in a 70 so as im passing them i look at my speedo and was doing almost 100 when the check engine light came on for a split second also wasnt very bright not like when you turn the key on got home used my tuner to scan and no stored codes im not sure what happened any ideas?
 

·
Registered
Joined
·
1,305 Posts
well if you were in in that deep couldve been an overboost or high egt....you should be fine....your trucks way of saying....WHOAAA
 

·
Registered
Joined
·
1,305 Posts
mine will do it when my egts(i have a gauge) get way up there...light comes on then off.by the way not good to get the egts that high.....i did it once never again
 

·
Registered
Joined
·
108 Posts
Discussion Starter #5
I figured it might be egts i dont have a gauge yet only had the truck a month and yes i have a Diablo predator tuner set on 85 hp
 

·
Registered
Joined
·
2,473 Posts
The truck doesn't have a PID for EGTs. Its more than likely a boost code or an ICP/IPR code.

Sent from my DROID RAZR using AutoGuide App
 

·
Registered
Joined
·
1,305 Posts
If your running a tuner you need gauges...at the very lesst an egt gauge
 

·
Registered
Joined
·
108 Posts
Discussion Starter #8
I know gauges already ordered soon to be installed
 

·
Registered
Joined
·
2,473 Posts
The gauges still won't point toward anything for a check engine light. High egt's will not set a CEL. Its just coincidence and nature of the beast....if you have high egt's the normally you are under hard acceleration. Which means you will be using more oil (which could set icp/ipr code) or making more boost that could set a boost code. And since it is under prolonged acceleration I would think its oil related. Its very normal under those conditions.

Sent from my DROID RAZR using AutoGuide App
 

·
Registered
Joined
·
1,305 Posts
correct...i was just pointing out that if running a tuner a tuner gauges are a neccesity
 

·
Registered
Joined
·
566 Posts
Likely an Overboost indication, will clear on its own. Typically happens at WOT with a tune that allows boost to exceed the stock 18-20 PSI. I believe over 25 PSI the indicator lights, but that is memory from a few years back running a tune and towing hard.

Good Luck

Coolhand
 

·
Registered
Joined
·
2,473 Posts
Likely an Overboost indication, will clear on its own. Typically happens at WOT with a tune that allows boost to exceed the stock 18-20 PSI. I believe over 25 PSI the indicator lights, but that is memory from a few years back running a tune and towing hard.

Good Luck

Coolhand
I was thinking the same thing...but I just remembered the MAP is only good to 23psi???

Sent from my DROID RAZR using AutoGuide App
 

·
Registered
Joined
·
62 Posts
Every single time I roll into the skinny pedal my check engine light comes on..... (not a flat foot) just going up a slight grade in over drive behind traffic... BAM light comes on... then as soon as I let off the accelerator it goes off... I scanned obdII and no codes shown....

*Running DP-85 econo tune*
 

·
Registered
Joined
·
1,366 Posts
Every single time I roll into the skinny pedal my check engine light comes on..... (not a flat foot) just going up a slight grade in over drive behind traffic... BAM light comes on... then as soon as I let off the accelerator it goes off... I scanned obdII and no codes shown....

*Running DP-85 econo tune*
OBDII won't read these trucks.

You'd need something like autoenginuity to read the codes.
 

·
Registered
Joined
·
62 Posts
KAaAaA-DUMPPPPP (that is the sound of another $359.95 hitting the bottom of the bucket :-/ )

I LOVE diesel trucks :sneaky:
 
1 - 16 of 16 Posts
Top