The Diesel Stop banner
1 - 7 of 7 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #1 ·
I have a 1992 f-350 and replaced the engine and wiring harness from a 1994 f-250. Problem is a hard shift. When I start it and shift into 1st I get no codes though it feels slugish. When it shifts into 2nd it shifts hard and flashes I have codes. I sent the cluster into "cluster fix" but still had the problem so I took it to a local shop as I am not a wiring guy. They told me after performing pin test 1-4 at 50 mph 4.5 max voltage but they got 5.48v and said programmable module was failed so cluster fix sent me a new one and I got no change. Where is my problem? My speedo is spot on with no noticed inconsistences. I am stuck please help.
 

·
Registered
Joined
·
17,604 Posts
Code 23 is the FIPL (TPS) out of range. Lots of threads here explaining how to set the correct voltage range.

Code 29 is a vehicle speed sensor issue. Could be the sensor or the wiring. Cluster isn't in the picture, and if the PSOM is getting bad information, changing it won't matter.
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #3 ·
Because my speedo is accurate how can it be my speed sensor?
 

·
Super Moderator
Joined
·
12,015 Posts
Code 23 is the FIPL (TPS) out of range. Lots of threads here explaining how to set the correct voltage range.
Code 23 means you didn't hold the accelerator pedal on the floor while running the key on engine off test. It does not mean you need to adjust the TPS.

Code 29 is a vehicle speed sensor issue. Could be the sensor or the wiring. Cluster isn't in the picture, and if the PSOM is getting bad information, changing it won't matter.
The cluster is getting the speedo information, but the PCM is not. This is your problem. Find why the PCM isn't seeing what the cluster is seeing.
 

·
Registered
Joined
·
2,195 Posts
How much of the wiring harness did you swap, exactly? This shows about HALF the wiring harness for one Bronco:



There were MANY changes to the wiring between '92 & '94, and even though many connectors are the same shape, their pinouts are different. Did you re-pin any of them?

This shows the basic '92-97 F-series PSOM circuit:

 

·
Registered
Joined
·
3,553 Posts
Since you changed the harness from a 94 to control a 92.

Do you still have the PCM relay under the hood drivers side next to the firewall hanging down?

Lots of wiring changes from 92 to 94, wire colors also.

IIRC, the speedo signal goes into the PSOM 1st, then to the PCM thru that relay.
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #7 ·
I have the whole engine wiring harness from the 1994. I changed several pins on the largest firewall pinout. There are two wires on the harness that had no matching wire but I am fairly sure they are for trailer wiring. At one point I replaced the pcm with the one out of the 94 but it made no change.
 
1 - 7 of 7 Posts
Top