The Diesel Stop banner

61 - 80 of 119 Posts

·
Registered
Joined
·
1,140 Posts
Update:

Just finished a week of towing my 9000 lbs 5th wheel all over Washington and Oregon. Covered 1500 miles. Average fuel MPG towing 60-70 MPH was 12.5 MPG. The truck ran great. No missing or crappy running. The Delphi cps in my opinion is much better than the grey Ford cps.

There's one long grade coming out of Mitchell, Oregon towards John Day, OR that is 6% for about 5 miles. Last year with the grey sensor I could barely hold 50 MPH in second gear. This time I pulled it at 55-60 in 3rd without a problem. Not a real scientific test, but more old a seat of the pants test. I'm going to keep it since its working good in my opinion.
I do not recall, did you ever try the BWD cps? If so, curious what you think in comparison between BWD and Delphi?

I did not do long enough tests, but I like the BWD better.
 

·
Registered
Joined
·
63 Posts
I did try the BWD sensor but it caused problems in the rain. The truck would randomly cut out. Glad to hear it works for you. I really with someone would check the perdels between them. The BWD and Delphi both made the truck run smoother, minus the problem with the BWD sensor.
 

·
Registered
Joined
·
1,140 Posts
I did try the BWD sensor but it caused problems in the rain. The truck would randomly cut out. Glad to hear it works for you. I really with someone would check the perdels between them. The BWD and Delphi both made the truck run smoother, minus the problem with the BWD sensor.
I think I recall you mentioning that now. I read somewhere that someone found a fix for the intermittent wiper issue. You have to add coils somewhere. If I can find it again, I will post it here.
 

·
Registered
Joined
·
99 Posts
I just ordered a HTS 101 Delphi CPS and this is what came out of the box. Grey CPS PN 1876735C91. Isnt this just the same international and ford **** in a different box? IMG_20140512_114337_835-1.jpg

What the hell?


Will the Delphi HTS 100 work?
 

·
Registered
Joined
·
2,831 Posts
to fix the wiper issue you need to shield the ground for the wiper motor.
adding a choke/ferrite beads to the ground will prevent the issue.
but i dont know where the ground is lol

ive ran the delphi and borg warner cps and the bg was better.
but the delphi i still better than the ford cps. better idle/starting/smother power.

ive ran three different ford cps and they all sucked. the delphi cps is better, and yes it does look the same.
 

·
Registered
Joined
·
127 Posts
I bought the bwd css626 (94-97 part) today to replace the IH. INSTANTLY SMOOTHER IDLE. No more off idle stumble, noticably smoother throttle response over the entire range. I haven't heard of this one having the wiper issue. I'll check tomorrow. $24.99 at Oreilly. We'll see if I get any fuel mileage increase. I lost 3 mpg from the recall and never got it back with the IH. In fact I've run the grey and the IH in the past week, no noticeable difference in idle or mileage, same off idle stumble.

Update~I have no issue with the intermittent wipers causing any kind of shutdown.
 

·
Registered
Joined
·
127 Posts
Update

I bought a css626 from O'reilly on Friday (March 20, and it got returned tonight, March 23). Truck idles instantly smoother, with a smooth throttle response. However, yesterday, it was randomly misfiring. Tach would drop a few hundred ROM, the would sputter and it nearly dies on the road. I put my IH Blue/gray unit back in. delphi is on order. They tried to not allow me to return it. I told them if I had to for 6 months I wouldn't try, but two days to failure is not happening. Then the "smart" one tried to tell me there was no warranty...so I showed him the lifetime warranty on the receipt.:SM130:
 

·
Registered
Joined
·
127 Posts
I just ordered a HTS 101 Delphi CPS and this is what came out of the box. Grey CPS PN 1876735C91. Isnt this just the same international and ford **** in a different box? View attachment 42577

What the hell?


Will the Delphi HTS 100 work?
I got the same POS from Rock Auto. Returning it immediately. looks like we are all stuck with garbage. Thanks Ford. :thdown:
 

·
Registered
Joined
·
127 Posts
No your not. Get a NAPA Echlin model and use snap on ferrite chokes.
Thanks!!


I assume the ferrite chokes are to stop the wiper issue? I can go get one tomorrow. Got a good source for the chokes?

Edit- They have them at Radio Shack if you still have one open near you.
 

·
Registered
Joined
·
172 Posts
I had a good, pre-recall CPS that Ford changed into the recall CPS that cost me about 4 mpg. Tried the BWD, but that one was worse so I took it back. I put in a dark grey one from RiffRaff and it was better but slowly got worse as well. Yesterday I put in the Delphi and it's ALMOST as good as the pre-recall one. Best so far. Mileage improved 3mpg driving the same loop as earlier in the day, with numbers on my lie-o-meter I have not seen in a long time, and the exhaust note is smoother and less cackle-y. I did note that the magnet seemed weaker of the three, but as long as it performs well I don't care.

When I took the dark grey out the o-ring was gone on one side, so it may have allowed the CPS to move a little causing the slow deterioration in performance.
 

·
Premium Member
Joined
·
3,754 Posts
Thanks!!


I assume the ferrite chokes are to stop the wiper issue? I can go get one tomorrow. Got a good source for the chokes?

Edit- They have them at Radio Shack if you still have one open near you.
You will need about a dozen ferrite chokes, they're as cheep as chips :lol: , 6 for the wiper loom and 4 for the Cps loom and a couple for the PCM ground, and body grounds.
Here's the wiper loom i did, i also used a water proof shrink wrap to cover it all .
Be careful to re-root the wiring loom when you've finished so it doesn't catch on the wiper arm.
 

Attachments

·
Registered
Joined
·
127 Posts
Nick, thanks for all the info. I got the Echlin CPS yesterday. I put two chokes on the wiper harness and the intermittent wipers no longer kill the truck. Smooth idle, smooth acceleration. ....until today. Cut out on me several times while driving. It drops about 300 RPM then kicks back on, did it several consecutive times. truck was at full temp. I put the IH CPS back in because it doesn't cut out on me. It's not raining here so I never touched the wipers. Will chokes on other locations cure this problem? I really like the smoother idle, but I'm not sure if my truck is going to let me get away with a better CPS. I did read the other thread, but I haven't seen any mention of random misfires.
 

·
Premium Member
Joined
·
7,913 Posts
I would choke it the exact same way I did. Snap them over each individual wire. It should be a snug fit. I also used a larger one to snap over ALL of the already choked wires after the individual chokes leaving the wiper motor. Since I've had it the way I do in my thread CPS Search and Effort Pay Off, there have been no shut offs with one snow storm where I plowed with them on for over 48 hrs. with the wipers on intermitant. I did this project in September. Lots of wiper use in all modes and about 7k miles.
 

·
Registered
Joined
·
172 Posts
I just ordered a HTS 101 Delphi CPS and this is what came out of the box. Grey CPS PN 1876735C91. Isnt this just the same international and ford **** in a different box? View attachment 42577

What the hell?


Will the Delphi HTS 100 work?
My Delphi has a different number , though it looks identical. I'll get the number off of it
 

·
Registered
Joined
·
127 Posts
Mine isn't shutting off, it got a nasty miss. My wipers weren't on. So I'm not sure it's got anything to do witht hat harness. I just wonder what other kind of noise and interference affects these sensors, and if it's a design flaw that makes mine cut out like it did, or if there is actually some other kind of EMI under the hood. I'll get some more chokes and do the sensor harness as well, wee is that works. I'll post up progress as I do more testing.
 

·
Premium Member
Joined
·
7,913 Posts
When I first put mine in, my dark blue International was giving me a miss I could feel in the steering wheel at idle. It was less than a year old. After a week of that I got nervous because I was going to the Ocean on vacation. I decided to replace it so I went to NAPA to get a CPS where it cut out completely in the parking lot. I had tried most all others on market so I tried the ELCHIN. Take off for Ocean three hours away with no problems. Couple nights later I'm in truck in front of restaurant in truck waiting for my table after ten minutes or so with the wipers on intermittent and that's when I felt the misses and then the stall. It did this once every day for two days till the rain stopped screwing up my vacation and the fishing. When I got home that's when I performed the choke installation outlined in my thread.
If yours is cutting out while moving please remove it untill you choke and test it as outlined in my thread.
 

·
Registered
Joined
·
127 Posts
I already put the IH CPS back in. I should have some time this week to add more chokes. I'm not sure they will fix it, it hasn't been raining and mine doesn't die when I turn on the intermittent wipers. I'll put the chokes on just to see of it works, because when it's not misfiring, it's very smooth.
 

·
Premium Member
Joined
·
7,913 Posts
It's Silky silky.. By any chance are your under valve cover harnesses after market or old? The reason I ask is they are shielded and might be causing an issue. Not sure exactly but I had stalls in my testing till I did it as outlined in my thread.
 
61 - 80 of 119 Posts
Top