The Diesel Stop banner

1 - 2 of 2 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter #1
I'm one of the outliers that has this engine in a non-Ford setting. 1988 International S1654 retired UHaul 27' box truck converted to a homemade flatbed car hauler. Has the 7.3 idi with a 5 speed manual. Complete old Battle-Axe, ugly as sin, rattles, clanks, air-ride tank has a leak so it rides like a 6x6 on a non-sprung steel beam (Which is kind of how they mounted the flat bed on it, etc. I bought it for a good price about 2.5 years ago and have miraculously managed to put about 7000 loaded miles on it while hobbying my car addiction around from time to time. She has always done a GREAT job, though I also always forget that and am very concerned that she is going to die on me the next time I use her. Yet she never does. Has 200K on the odo and had that when I got her and the people from whom I got her said the odo had been broken as long as they remembered, so she's probably got at least 250K, low-maintenance (I am guessing from her appearances) miles on her.
I am prepping to leave on about an 1100 mile trip with a '96 Yukon on back and a '98 Sidekick flat-towed behind. I have taken a couple of recent 100-130 mile days with her to make sure she is up to the task. At some point this spring or summer, she was having an air intrusion issue. On a couple of occasions I had to crack open the injector lines and bleed the fuel out to them. I then replaced the fuel filter (was STUCK on there and FILTHY, and lord knows how many miles it had on it!), having done some research that said that was a common place for air intrusion. It apparently was the problem, as it no longer seems to have an air into the fuel line kind of issue. She has ALWAYS needed a spritz of starter fluid to start if cold since I got her, and, again, the prior owners said they had run her that way for years.
Today, after putting about 40 miles and a lot of idling on her, I stopped at a store to grab some stuff. I came out and she was still warm which would often allow her to start without any starter fluid, and she did-and ran for about 5 seconds, and then cut off cold! I tried to restart. Nope-turns over but no start. I tried this a couple of times, then got the starter fluid out to see, and she tried MUCH harder to actually start and run, but wouldn't quite go. I hadn't had this problem before, so decided to sit in the parking lot for a few minutes and let her breathe out the last squirt of starter fluid before I tried again. I got on my phone and looked up this site and did a little searching, and while I was sitting there reading some threads, I hear and feel a sizeable, definitely SOMETHING on my truck, BOOM! I look around onto the flatbed to see if something I had on there had fallen, etc, and then remembered that I had heard and felt a similar boom a couple of times since changing that fuel filter. And it had always felt to me like it was coming from the passenger side in the area of the fuel tank. My brain then recalled that when I go to fuel up, there is always a LOT of suction/vacuum in the tank, as when I start to turn the gas cap (remember, this is a big old U-Haul, so it is the typical, external, side hanging under the passenger door step fuel tank with the old BRASS looking SOLID metal gas cap-no fancy vented, plastic, ratchet turning and tightening thing!) to remove it, I always get a LOT of whistling/sucking air sounds. It then dawned on me that apparently I was getting NO air into the fuel system, and perhaps THIS was the problem with why it had just cut out on me and why it would not start. SO, I cracked the gas cap-PSSSSSHSHSHSHSHS-it sucks in air. I keep opening the cap, it keeps sucking air. I new get in to start it and it does start-runs a little funny for 20 or 30 seconds sorting itself out, and then goes back to idling normally.
So I had already called a buddy that's a pretty experienced diesel mech kind of guy for a young feller (25 or so, I guess), and he was in the neighborhood and had offered to come by and help me out. Well, I immediately texted him, told him I had gotten it started and was running it to my house in case it tried to die again, and asked him to meet me there. I made it home, he came by and I mentioned my thoughts to him that I was not getting ANY air into the fuel line and thus, the fuel pumps were not able to suck fuel through the system. He instantly agreed that this could be a problem, mentioned that he had known some equipment before that had had this issue, and that I SHOULD have a vent somewhere on that tank that must be stopped up.
So, my question here simply is, do YOU GUYS think that could be the issue here. As I said, it was never a problem before, but I am pretty sure that old fuel filter has probably been letting SOME small amount of air into the system for a long time, and this may have been counteracting the clogged vent. Once I replaced the filter, perhaps it is truly not getting enough air to allow for the suction of the mechanical pump to pull fuel through against the vacuum created by the tightly sealed tank. I would really LOVE to get on the road within the next 2 days, and am not sure if I will have time to thoroughly look for the problem venting or not, so may just try driving with the fuel cap a little loose to see if that allows the truck to run with no problems. Basically, it is already getting cold up here in MI and I would MUCH rather get it to GA before I have to dig into it and work on it too much. I had Covid 2 weeks ago and was laid up and missed out on the last of our nice weather to work on the ting before the big trip.
Input?
Thanks for any thoughts or ideas on this.
 

·
Registered
Joined
·
1,742 Posts
A tank without ventilation will collapse down to nothing if the fuel system is strong enough to keep running. Used to happen to the old 60s and 70s model gassers with the vented cap, especially when they went to the non vented caps with the ventilation system doing EPA stuff. There was some confusion between vented and non vented.
 
1 - 2 of 2 Posts
Top