The Diesel Stop banner

E4OD wiring diagram

36821 Views 10 Replies 6 Participants Last post by  danjreed
How do I trouble shoot the TC circuit without a scan tool?

I know there is the purple wire with yellow stripe, it should lock up if I ground that.

So where does it get it's power? Is there more than one wire that controls or supplies power to the TC convertor.

I am looking for ways to test the TC circuit inside the tranny so I can figure out if my problem is internal or external.
1 - 4 of 11 Posts
Bringing this back since I finally got a little time to mess with it.

So I grounded the purple and yellow wire. With the truck running. I thought I read somewhere that even in park it should try to engage the TQ, is that right?

When I grounded it, nothing happened. I put a test light on it, and I have voltage coming out of the transmission in the purple/yellow wire, so that at least means I have continuity through the solenoid pack right?

I thought I had a astg manual for it, but I can't find it after the move.
Is that the only thing in that circuit?
Should I just buy a solenoid and put it in?

<div class="ubbcode-block"><div class="ubbcode-header">Originally Posted By: Mark Kovalsky</div><div class="ubbcode-body">
Locking the torque converter in park causes absolutely nothing to happen!


Cool, that will help. So I was testing it wrong.

There may be hope yet. If the thing tried to lock up, which I hope it does, then I know my problem is someplace else, not in the TC, or solenoids.
Well just an update in case someone else has this problem.
I had the wife, (yes I trust her with my life) put the truck in gear and foot on the brake.
I grounded the purple wire with yellow stripe, and the truck died.
That circuit is working fine.
With just the key on, engine not running you can ground the purple wire and hear the solenoid click.

What has happened is the Gear vendor actually breaks the purple wire, it comes from the tranny, through the GV control module and back to PCM? or where ever it goes.
The GV module apparently is bad, and burn open? or relay is stuck open not allowing the circuit to continue, even though it is switched off, and power removed.
Bypassed the GV controls, unhooked the batteries for a couple minutes and all is well.
When I installed the GV I bought all new updated stuff from GV and it worked perfectly for years. All the sudden one day it stopped working, and it has been one problem after another with it since.
I think it is a great unit, but we are making our own control module.
See less See more
1 - 4 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.