The Diesel Stop banner
1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I am on my 3rd Ford Diesel and finally decided to join after voicelessly reading this forum for the last 5 years or so. Without being a member it can be quite difficult to find a thread relating to your problem. My first diesel was a 92 with the 7.3 non turbo. I bought it off an old man who kept it in amazing shape. I drove it all over the country. It was a long bed extended cab. The non-turbo kind of stank, it was slow and took forever to get going, but it would pull anything I could put behind it. Then winter hit and I found out the glow plugs didn't work. Took me several weeks and nights pouring over this form to discover my glow plug mod. had melted itself. So after weeks of starter fluid I made my first diesel repair. One night in particular was horrible, I got out of class super late (around midnight) and it was about 20 degrees outside (very unusual for Oklahoma) and the truck would not start. I needed up walking almost 2 miles to an alright gas station because I was out of starting fluid. So once I got the truck fixed I was pleased for several more weeks before I got it buried to the axle after a light rain. I pulled it in the back yard to get a trailer out. My friends F150 had blown a spark plug threw the hood (gotta love the Ford 5.4) so I was trying to pull the trailer and truck around. My friend ended up pulling me out with his tiny Nissan 4x4. We attracted an audience. I put the truck for sale that day and sold it two days later and paid cash for a 2003 Crew Cab, 6.0 long bed FX4! It was my first 4wd and it was amazing. I paid 8k for the truck with 160k on it (that should have been my first sign) and I didn't know anything about the 6.0. Two days after I bought it the erg cooler blew and I lost all my antifreeze in the taco bell parking lot. They actually ran out and were trying to call the fire department. I assured them the truck was not on fire! lol So after fixing that the truck was nothing but problems for the next 2.5 years. I found out the engine was out of an 06 and the heads were off an 04, and the head gaskets were blown so I didn't have heat... or the ability to drive the truck when it was below 90 outside until the truck warmed up for awhile. So 2 weeks ago I decided to trade up! I wanted a 6.4 and a truck that didn't have so many issues. I actually got 8500 for my trade and got a 2008 crew cab Fx4 with a 6.4. Now the down side, to buy one I could afford it has 205k on it. But runs great. The only problem it is having is popping the number 35 fuse which controls the 4x4 and the OD and back up sensors. I will begin my search on here for a solution to that problem. I know my 03 had an issue with the OD shifter causing issues but would that still be the issue on a 2008? Anyway, its good to be here! Hope to get to know some of you! Sorry for my long winded introduction, just wanted to give some background!
 

·
Premium Member
Joined
·
2,197 Posts
Welcome aboard mate.

Really surprise that nissan was able to tow lol
 
1 - 4 of 4 Posts
Top