The Diesel Stop banner
1 - 4 of 4 Posts

·
Registered
1993 F350, 7.3l idi-nonturbo, ZF-5, 4x4, Crew Cab Long Box, tu-tone Blue, Stock
Joined
·
2 Posts
Discussion Starter · #1 ·
There has been slow clicking when the wait to start light comes on and the battery gauge swings about halfway every click, but it started ok. This has been happening since I bought it (this summer) but just recently it has stopped starting. This may have something to do with the fact that the key was left on, I tried jumping and charging it but it just turns really slow. I think it is the glow plugs, or maybe the relay. Could also be the batteries but their not stock.
 

·
Registered
Joined
·
4,983 Posts
It could be the alternator, batteries or starter. Glow plugs do draw amps but engine should still spin over fast. How old are the batteries? Did you charge them overnight? If they test good, test the starter, once you do get it running test the alternator. DENNY
 

·
Registered
1993 F350, 7.3l idi-nonturbo, ZF-5, 4x4, Crew Cab Long Box, tu-tone Blue, Stock
Joined
·
2 Posts
Discussion Starter · #3 ·
It could be the alternator, batteries or starter. Glow plugs do draw amps but engine should still spin over fast. How old are the batteries? Did you charge them overnight? If they test good, test the starter, once you do get it running test the alternator. DENNY
Ok, thanks. I'll try that
 

·
Registered
Joined
·
1,871 Posts
Check your glow plugs. That is a common sign that one or more of them are either dead or dying.
 
1 - 4 of 4 Posts
Top