The Diesel Stop banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
2008 F-450 Super Duty Lariat. We just purchased the truck and GPS won't find truck. Shows it about 600 miles away.

We tried resetting the GPS and that did not solve it. Any other ways to fix the gps? Is there a chip that needs replacing or is the whole radio/nav system have to be replaced?

Any info is appreciated.

Thanks
 

·
Premium Member
Joined
·
3,916 Posts
How long have you allowed the GPS to remain on and to acquire your new location?

It can take 10-15 minutes after it has been powered off for awhile.

It likely is showing the location where it was last used.
 

·
Premium Member
Joined
·
3,916 Posts
Does your clock still work?

Does your screen say NO GPS in upper left corner?

How many GPS Signals does it show?

Do you have any items laying on your dash that may be blocking the antenna from receiving signal.

Have you performed the self-diagnostic test by pushing 3 & 6 together for 3 seconds? Then the END TEST and this will show the DTC screen. B2244 indicates the antenna is not connected. It may have come loose from back of unit.

But first sep is to drive around for 10 minutes and allow the receiver to acquire GPS signal for the new location.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Does your clock still work? NO

Does your screen say NO GPS in upper left corner? YES

How many GPS Signals does it show? NOT SURE WHAT YOU MEAN BY THIS

Do you have any items laying on your dash that may be blocking the antenna from receiving signal. NO

Have you performed the self-diagnostic test by pushing 3 & 6 together for 3 seconds? Then the END TEST and this will show the DTC screen. B2244 indicates the antenna is not connected. It may have come loose from back of unit. WE DID THIS AND IT SAYS B2204.

But first sep is to drive around for 10 minutes and allow the receiver to acquire GPS signal for the new location.

Thanks for your suggestions. See the answers to your questions above. The truck came straight from Washington State so there is no reason it would have been showing Windsor Ontario. which is the 600 miles away.

We reset it again and it shows the arrow in the correct location when set. I set a destination and it showed the path correctly. But when we start driving it shows us going in all kinds of directions and the map seems to spin around. It kept trying to reset for the destination. It kept going nuts so I turned the destination off. We ended up in the middle of a lake according to the nav. We drove it for at least 30 minutes so it should have had time to calibrate.

We are planning to pull the radio and make sure the antenna is connected. Any other ideas?

Thanks,
 
1 - 4 of 4 Posts
Top